[65/83] sim: riscv: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-66-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The arch-specific compiler flags are duplicated, but they'll be cleaned
up once we move all subdir compiles to the top-level.
---
 sim/Makefile.in    | 4 +---
 sim/riscv/local.mk | 5 ++---
 2 files changed, 3 insertions(+), 6 deletions(-)
  

Patch

diff --git a/sim/riscv/local.mk b/sim/riscv/local.mk
index 6f03fc3d0346..a77f6f74317d 100644
--- a/sim/riscv/local.mk
+++ b/sim/riscv/local.mk
@@ -16,6 +16,8 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+AM_CPPFLAGS_%C% = -DWITH_TARGET_WORD_BITSIZE=$(SIM_RISCV_BITSIZE)
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -30,9 +32,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)