[76/83] sim: common: simplify hw-config.h deps

Message ID 20230103075605.13606-77-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  Now that all ports (other than ppc) build in the top-level, we don't
need to expand all the hw-config.h targets as a recursive dep.  Each
port depends on their respective header now, and the ppc port doesn't
use it at all.
---
 sim/Makefile.in     | 19 +++++++++----------
 sim/common/local.mk |  5 ++---
 2 files changed, 11 insertions(+), 13 deletions(-)
  

Patch

diff --git a/sim/common/local.mk b/sim/common/local.mk
index 2c68f668d37c..c297668b0be9 100644
--- a/sim/common/local.mk
+++ b/sim/common/local.mk
@@ -131,9 +131,8 @@  endif
 	touch $@
 .PRECIOUS: %/stamp-hw
 
-%C%_HW_CONFIG_H_TARGETS = $(patsubst %,%/hw-config.h,$(SIM_ENABLED_ARCHES))
-MOSTLYCLEANFILES += $(%C%_HW_CONFIG_H_TARGETS) $(patsubst %,%/stamp-hw,$(SIM_ENABLED_ARCHES))
-SIM_ALL_RECURSIVE_DEPS += $(%C%_HW_CONFIG_H_TARGETS)
+%C%_HW_CONFIG_H_TARGETS = $(SIM_ENABLED_ARCHES:%=%/hw-config.h)
+MOSTLYCLEANFILES += $(%C%_HW_CONFIG_H_TARGETS) $(SIM_ENABLED_ARCHES:%=%/stamp-hw)
 
 ## See sim_pre_argv_init and sim_module_install in sim-module.c for more details.
 ## TODO: Switch this to xxx_SOURCES once projects build objects in local.mk.