[31/83] sim: rl78: move libsim.a creation to top-level

Message ID 20230103075605.13606-32-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in      | 83 ++++++++++++++++++++++++++++++--------------
 sim/rl78/Makefile.in | 12 ++-----
 sim/rl78/local.mk    | 24 ++++++++++---
 3 files changed, 78 insertions(+), 41 deletions(-)
  

Patch

diff --git a/sim/rl78/Makefile.in b/sim/rl78/Makefile.in
index 9ca400efe283..0cc55baf3b5a 100644
--- a/sim/rl78/Makefile.in
+++ b/sim/rl78/Makefile.in
@@ -20,15 +20,7 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-SIM_RUN_OBJS = \
-	main.o
-
-SIM_OBJS = \
-	load.o \
-	mem.o \
-	cpu.o \
-	rl78.o \
-	gdb-if.o \
-	trace.o
+SIM_LIBSIM =
+SIM_RUN_OBJS =
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/rl78/local.mk b/sim/rl78/local.mk
index 07ff86711c16..935fbf1eea07 100644
--- a/sim/rl78/local.mk
+++ b/sim/rl78/local.mk
@@ -16,6 +16,26 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/load.o \
+	%D%/mem.o \
+	%D%/cpu.o \
+	%D%/rl78.o \
+	%D%/gdb-if.o \
+	%D%/modules.o \
+	%D%/trace.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/main.o \
@@ -23,7 +43,3 @@ 
 	$(SIM_COMMON_LIBS)
 
 noinst_PROGRAMS += %D%/run
-
-## Helper targets for running make from the top-level due to run's main.o.
-%D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)