[06/83] sim: avr: move libsim.a creation to top-level

Message ID 20230103075605.13606-7-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:54 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in     | 266 +++++++++++++++++++++++++-------------------
 sim/avr/Makefile.in |   5 +-
 sim/avr/local.mk    |  18 +++
 3 files changed, 168 insertions(+), 121 deletions(-)
  

Patch

diff --git a/sim/avr/Makefile.in b/sim/avr/Makefile.in
index 579c2322c5ba..eaf6c4b6a977 100644
--- a/sim/avr/Makefile.in
+++ b/sim/avr/Makefile.in
@@ -16,9 +16,6 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-SIM_OBJS = \
-	interp.o \
-	$(SIM_NEW_COMMON_OBJS) \
-	sim-resume.o
+SIM_LIBSIM =
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/avr/local.mk b/sim/avr/local.mk
index a667abd839f4..84ba9d6f6e4f 100644
--- a/sim/avr/local.mk
+++ b/sim/avr/local.mk
@@ -15,6 +15,24 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/interp.o \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/modules.o \
+	%D%/sim-resume.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \