[07/83] sim: bfin: move libsim.a creation to top-level

Message ID 20230103075605.13606-8-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:54 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in      | 274 +++++++++++++++++++++++++------------------
 sim/bfin/Makefile.in |   9 +-
 sim/bfin/local.mk    |  23 ++++
 3 files changed, 181 insertions(+), 125 deletions(-)
  

Patch

diff --git a/sim/bfin/Makefile.in b/sim/bfin/Makefile.in
index 2ecad1d8af7b..700e641d149c 100644
--- a/sim/bfin/Makefile.in
+++ b/sim/bfin/Makefile.in
@@ -19,14 +19,7 @@ 
 
 arch = bfin
 
-SIM_OBJS = \
-	$(SIM_NEW_COMMON_OBJS) \
-	bfin-sim.o \
-	devices.o \
-	gui.o \
-	interp.o \
-	machs.o \
-	sim-resume.o
+SIM_LIBSIM =
 
 SIM_EXTRA_CFLAGS = $(SDL_CFLAGS)
 
diff --git a/sim/bfin/local.mk b/sim/bfin/local.mk
index 80df254c786f..95bc73000cb8 100644
--- a/sim/bfin/local.mk
+++ b/sim/bfin/local.mk
@@ -16,6 +16,29 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	$(patsubst %,%D%/dv-%.o,$(%C%_SIM_EXTRA_HW_DEVICES)) \
+	%D%/bfin-sim.o \
+	%D%/devices.o \
+	%D%/gui.o \
+	%D%/interp.o \
+	%D%/machs.o \
+	%D%/modules.o \
+	%D%/sim-resume.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \