[49/83] sim: frv: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-50-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The arch-specific flags are only used by the arch-specific modules,
not the common/ files, so we can delete them too.
---
 sim/Makefile.in     | 6 +++---
 sim/frv/Makefile.in | 6 ------
 sim/frv/local.mk    | 9 ++++++---
 3 files changed, 9 insertions(+), 12 deletions(-)
  

Patch

diff --git a/sim/frv/Makefile.in b/sim/frv/Makefile.in
index f577873c057a..d898bcbc2493 100644
--- a/sim/frv/Makefile.in
+++ b/sim/frv/Makefile.in
@@ -16,12 +16,6 @@ 
 # along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 ## COMMON_PRE_CONFIG_FRAG
-
-SIM_EXTRA_CFLAGS = @SIM_FRV_TRAPDUMP_FLAGS@
-
-# Some modules don't build cleanly yet.
-memory.o sem.o: SIM_WERROR_CFLAGS =
-
 ## COMMON_POST_CONFIG_FRAG
 
 arch = frv
diff --git a/sim/frv/local.mk b/sim/frv/local.mk
index 2451235d2385..a060a46ffa8f 100644
--- a/sim/frv/local.mk
+++ b/sim/frv/local.mk
@@ -16,6 +16,12 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+AM_CPPFLAGS_%C% = $(SIM_FRV_TRAPDUMP_FLAGS)
+
+## Some modules don't build cleanly yet.
+AM_CFLAGS_%C%_memory.o = -Wno-error
+AM_CFLAGS_%C%_sem.o = -Wno-error
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -57,9 +63,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)