[59/83] sim: mips: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-60-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The arch-specific compiler flags are duplicated, but they'll be cleaned
up once we move all subdir compiles to the top-level.
---
 sim/Makefile.in   | 8 +++++---
 sim/mips/local.mk | 8 +++++---
 2 files changed, 10 insertions(+), 6 deletions(-)
  

Patch

diff --git a/sim/mips/local.mk b/sim/mips/local.mk
index f255ffca611f..c25e50b1d65f 100644
--- a/sim/mips/local.mk
+++ b/sim/mips/local.mk
@@ -16,6 +16,11 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+AM_CPPFLAGS_%C% = \
+	@SIM_MIPS_SUBTARGET@ \
+	-DWITH_TARGET_WORD_BITSIZE=@SIM_MIPS_BITSIZE@ -DWITH_TARGET_WORD_MSB=WITH_TARGET_WORD_BITSIZE-1 \
+	-DWITH_FLOATING_POINT=HARD_FLOATING_POINT -DWITH_TARGET_FLOATING_POINT_BITSIZE=@SIM_MIPS_FPU_BITSIZE@
+
 %C%_GEN_OBJ =
 if SIM_MIPS_GEN_MODE_SINGLE
 %C%_GEN_OBJ += \
@@ -69,9 +74,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)