[47/83] sim: erc32: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-48-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The arch-specific flags are only used by the arch-specific modules,
not the common/ files, so we can delete them too.
---
 sim/Makefile.in       |  6 +++---
 sim/erc32/Makefile.in | 10 ----------
 sim/erc32/local.mk    | 11 ++++++++---
 3 files changed, 11 insertions(+), 16 deletions(-)
  

Patch

diff --git a/sim/erc32/Makefile.in b/sim/erc32/Makefile.in
index 58afbe1f7476..adff308c23b3 100644
--- a/sim/erc32/Makefile.in
+++ b/sim/erc32/Makefile.in
@@ -17,14 +17,4 @@ 
 # along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 ## COMMON_PRE_CONFIG_FRAG
-
-READLINE_SRC = $(srcroot)/readline/readline
-
-SIM_EXTRA_CFLAGS = $(READLINE_CFLAGS)
-
-# UARTS run at about 115200 baud (simulator time). Add -DFAST_UART to
-# CFLAGS if faster (infinite) UART speed is desired. Might affect the
-# behaviour of UART interrupt routines ...
-SIM_EXTRA_CFLAGS += -DFAST_UART
-
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/erc32/local.mk b/sim/erc32/local.mk
index 7c95128a1668..12aced4bafa4 100644
--- a/sim/erc32/local.mk
+++ b/sim/erc32/local.mk
@@ -17,6 +17,14 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+READLINE_SRC = $(srcroot)/readline/readline
+AM_CPPFLAGS_%C% = $(READLINE_CFLAGS)
+
+## UARTS run at about 115200 baud (simulator time). Add -DFAST_UART to
+## CFLAGS if faster (infinite) UART speed is desired. Might affect the
+## behaviour of UART interrupt routines ...
+AM_CPPFLAGS_%C% += -DFAST_UART
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -31,9 +39,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)