[05/83] sim: arm: move libsim.a creation to top-level

Message ID 20230103075605.13606-6-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:54 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in     | 278 +++++++++++++++++++++++++-------------------
 sim/arm/Makefile.in |   7 +-
 sim/arm/local.mk    |  21 ++++
 3 files changed, 181 insertions(+), 125 deletions(-)
  

Patch

diff --git a/sim/arm/Makefile.in b/sim/arm/Makefile.in
index 9dda82be86f1..cdf371d844c7 100644
--- a/sim/arm/Makefile.in
+++ b/sim/arm/Makefile.in
@@ -19,11 +19,6 @@ 
 
 SIM_EXTRA_CFLAGS = -DMODET
 
-SIM_OBJS = \
-	wrapper.o \
-	$(SIM_NEW_COMMON_OBJS) \
-	armemu.o armemu32.o arminit.o armos.o armsupp.o \
-	armvirt.o thumbemu.o \
-	armcopro.o maverick.o iwmmxt.o
+SIM_LIBSIM =
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/arm/local.mk b/sim/arm/local.mk
index 4bbbf92cc741..e3ce50fc81ab 100644
--- a/sim/arm/local.mk
+++ b/sim/arm/local.mk
@@ -16,6 +16,27 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/wrapper.o \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/armemu.o \
+	%D%/armemu32.o %D%/arminit.o %D%/armos.o %D%/armsupp.o \
+	%D%/armvirt.o %D%/thumbemu.o \
+	%D%/armcopro.o %D%/maverick.o %D%/iwmmxt.o \
+	%D%/modules.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \