[21/83] sim: m68hc11: move libsim.a creation to top-level

Message ID 20230103075605.13606-22-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in         | 168 +++++++++++++++++++++++++---------------
 sim/m68hc11/Makefile.in |   7 +-
 sim/m68hc11/local.mk    |  24 ++++++
 3 files changed, 132 insertions(+), 67 deletions(-)
  

Patch

diff --git a/sim/m68hc11/Makefile.in b/sim/m68hc11/Makefile.in
index 04b926c48c2c..f67a94cf9401 100644
--- a/sim/m68hc11/Makefile.in
+++ b/sim/m68hc11/Makefile.in
@@ -19,12 +19,7 @@ 
 
 arch = m68hc11
 
-M68HC11_OBJS = interp.o m68hc11int.o m68hc12int.o \
-		emulos.o interrupts.o m68hc11_sim.o
-
-SIM_OBJS = $(M68HC11_OBJS) \
-	$(SIM_NEW_COMMON_OBJS) \
-	sim-resume.o
+SIM_LIBSIM =
 
 # We must use 32-bit addresses to support memory bank switching.
 # The WORD_BITSIZE is normally 16 but must be switched (temporarily)
diff --git a/sim/m68hc11/local.mk b/sim/m68hc11/local.mk
index d2e04576a771..9b52df6b533c 100644
--- a/sim/m68hc11/local.mk
+++ b/sim/m68hc11/local.mk
@@ -16,6 +16,30 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/interp.o \
+	%D%/m68hc11int.o \
+	%D%/m68hc12int.o \
+	%D%/emulos.o \
+	%D%/interrupts.o \
+	%D%/m68hc11_sim.o \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	$(patsubst %,%D%/dv-%.o,$(%C%_SIM_EXTRA_HW_DEVICES)) \
+	%D%/modules.o \
+	%D%/sim-resume.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \