[28/83] sim: or1k: move libsim.a creation to top-level

Message ID 20230103075605.13606-29-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in      | 118 +++++++++++++++++++++++++++++++------------
 sim/or1k/Makefile.in |  22 +-------
 sim/or1k/local.mk    |  34 +++++++++++++
 3 files changed, 122 insertions(+), 52 deletions(-)
  

Patch

diff --git a/sim/or1k/Makefile.in b/sim/or1k/Makefile.in
index ca5bf1ae4eee..19eed022932d 100644
--- a/sim/or1k/Makefile.in
+++ b/sim/or1k/Makefile.in
@@ -18,27 +18,7 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-OR1K_OBJS = \
-	or1k.o \
-	arch.o \
-	cpu.o \
-	decode.o \
-	model.o \
-	sem.o \
-	mloop.o \
-	sim-if.o \
-	traps.o
-
-SIM_OBJS = \
-	$(SIM_NEW_COMMON_OBJS) \
-	cgen-utils.o \
-	cgen-trace.o \
-	cgen-scache.o \
-	cgen-run.o \
-	cgen-fpu.o \
-	cgen-accfp.o
-
-SIM_OBJS += $(OR1K_OBJS)
+SIM_LIBSIM =
 
 SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=32 -DWITH_TARGET_WORD_MSB=31
 
diff --git a/sim/or1k/local.mk b/sim/or1k/local.mk
index 7d999f6f3aa4..a7412bfa07ce 100644
--- a/sim/or1k/local.mk
+++ b/sim/or1k/local.mk
@@ -15,6 +15,40 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/modules.o \
+	\
+	%D%/cgen-accfp.o \
+	%D%/cgen-fpu.o \
+	%D%/cgen-run.o \
+	%D%/cgen-scache.o \
+	%D%/cgen-trace.o \
+	%D%/cgen-utils.o \
+	\
+	%D%/arch.o \
+	%D%/cpu.o \
+	%D%/decode.o \
+	%D%/mloop.o \
+	%D%/model.o \
+	%D%/sem.o \
+	\
+	%D%/or1k.o \
+	%D%/sim-if.o \
+	%D%/traps.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \