[43/83] sim: bfin: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-44-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The arch-specific flags are only used by the arch-specific modules,
not the common/ files, so we can delete them too.
---
 sim/Makefile.in      | 4 +---
 sim/bfin/Makefile.in | 2 --
 sim/bfin/local.mk    | 5 ++---
 3 files changed, 3 insertions(+), 8 deletions(-)
  

Patch

diff --git a/sim/bfin/Makefile.in b/sim/bfin/Makefile.in
index 569c64bb22f5..472bb48e6723 100644
--- a/sim/bfin/Makefile.in
+++ b/sim/bfin/Makefile.in
@@ -19,6 +19,4 @@ 
 
 arch = bfin
 
-SIM_EXTRA_CFLAGS = $(SDL_CFLAGS)
-
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/bfin/local.mk b/sim/bfin/local.mk
index 95bc73000cb8..d3c5b17a82b9 100644
--- a/sim/bfin/local.mk
+++ b/sim/bfin/local.mk
@@ -16,6 +16,8 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+AM_CPPFLAGS_%C% = $(SDL_CFLAGS)
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -33,9 +35,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)