[55/83] sim: m32r: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-56-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  ---
 sim/Makefile.in      | 15 ++++++++++++---
 sim/m32r/Makefile.in |  3 ---
 sim/m32r/local.mk    | 17 ++++++++++++++---
 3 files changed, 26 insertions(+), 9 deletions(-)
  

Patch

diff --git a/sim/m32r/Makefile.in b/sim/m32r/Makefile.in
index bc7b85694792..43346b8b9849 100644
--- a/sim/m32r/Makefile.in
+++ b/sim/m32r/Makefile.in
@@ -21,7 +21,4 @@ 
 
 arch = m32r
 
-# Some modules don't build cleanly yet.
-cpu.o cpu2.o cpux.o m32r.o m32r2.o m32rx.o mloop.o mloop2.o mloopx.o sem.o sim-if.o traps.o: SIM_WERROR_CFLAGS =
-
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/m32r/local.mk b/sim/m32r/local.mk
index afecaf6c8bce..3ccfce79b095 100644
--- a/sim/m32r/local.mk
+++ b/sim/m32r/local.mk
@@ -16,6 +16,20 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+## Some modules don't build cleanly yet.
+AM_CFLAGS_%C%_cpu.o = -Wno-error
+AM_CFLAGS_%C%_cpu2.o = -Wno-error
+AM_CFLAGS_%C%_cpux.o = -Wno-error
+AM_CFLAGS_%C%_m32r.o = -Wno-error
+AM_CFLAGS_%C%_m32r2.o = -Wno-error
+AM_CFLAGS_%C%_m32rx.o = -Wno-error
+AM_CFLAGS_%C%_mloop.o = -Wno-error
+AM_CFLAGS_%C%_mloop2.o = -Wno-error
+AM_CFLAGS_%C%_mloopx.o = -Wno-error
+AM_CFLAGS_%C%_sem.o = -Wno-error
+AM_CFLAGS_%C%_sim_if.o = -Wno-error
+AM_CFLAGS_%C%_traps.o = -Wno-error
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -56,9 +70,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)