[08/83] sim: bpf: move libsim.a creation to top-level

Message ID 20230103075605.13606-9-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:54 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in     | 285 ++++++++++++++++++++++++++------------------
 sim/bpf/Makefile.in |  13 +-
 sim/bpf/local.mk    |  35 ++++++
 3 files changed, 207 insertions(+), 126 deletions(-)
  

Patch

diff --git a/sim/bpf/Makefile.in b/sim/bpf/Makefile.in
index 2732a0e6071e..1fc98a68cbe5 100644
--- a/sim/bpf/Makefile.in
+++ b/sim/bpf/Makefile.in
@@ -18,18 +18,7 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-CGEN_STD_OBJS = cgen-run.o cgen-scache.o cgen-trace.o cgen-utils.o
-BPF_GEN_OBJS = arch.o cpu.o \
-               decode-le.o decode-be.o \
-               sem-le.o sem-be.o \
-               mloop-le.o mloop-be.o
-BPF_HAND_OBJS = bpf.o sim-if.o traps.o bpf-helpers.o
-
-SIM_OBJS = \
-	$(SIM_NEW_COMMON_OBJS) \
-	$(CGEN_STD_OBJS) \
-	$(BPF_GEN_OBJS) \
-	$(BPF_HAND_OBJS)
+SIM_LIBSIM =
 
 SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=64
 
diff --git a/sim/bpf/local.mk b/sim/bpf/local.mk
index f86f3306a8a9..19dcc25736c1 100644
--- a/sim/bpf/local.mk
+++ b/sim/bpf/local.mk
@@ -15,6 +15,41 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/modules.o \
+	\
+	%D%/cgen-run.o \
+	%D%/cgen-scache.o \
+	%D%/cgen-trace.o \
+	%D%/cgen-utils.o \
+	\
+	%D%/arch.o \
+	%D%/cpu.o \
+	%D%/decode-le.o \
+	%D%/decode-be.o \
+	%D%/sem-le.o \
+	%D%/sem-be.o \
+	%D%/mloop-le.o \
+	%D%/mloop-be.o \
+	\
+	%D%/bpf.o \
+	%D%/bpf-helpers.o \
+	%D%/sim-if.o \
+	%D%/traps.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \