[32/83] sim: rx: move libsim.a creation to top-level

Message ID 20230103075605.13606-33-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in    | 86 ++++++++++++++++++++++++++++++++--------------
 sim/rx/Makefile.in | 15 ++------
 sim/rx/local.mk    | 28 ++++++++++++---
 3 files changed, 87 insertions(+), 42 deletions(-)
  

Patch

diff --git a/sim/rx/Makefile.in b/sim/rx/Makefile.in
index 28d13bed0abd..c418da28944a 100644
--- a/sim/rx/Makefile.in
+++ b/sim/rx/Makefile.in
@@ -22,18 +22,7 @@ 
 
 SIM_EXTRA_CFLAGS = @SIM_RX_CYCLE_ACCURATE_FLAGS@
 
-SIM_RUN_OBJS = main.o
-
-SIM_OBJS = \
-	fpu.o \
-	load.o \
-	mem.o \
-	misc.o \
-	reg.o \
-	rx.o \
-	syscalls.o \
-	trace.o \
-	gdb-if.o \
-	err.o
+SIM_LIBSIM =
+SIM_RUN_OBJS =
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/rx/local.mk b/sim/rx/local.mk
index 00978e9d0311..c23ac4f8035c 100644
--- a/sim/rx/local.mk
+++ b/sim/rx/local.mk
@@ -16,6 +16,30 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/fpu.o \
+	%D%/load.o \
+	%D%/mem.o \
+	%D%/misc.o \
+	%D%/reg.o \
+	%D%/rx.o \
+	%D%/syscalls.o \
+	%D%/trace.o \
+	%D%/gdb-if.o \
+	%D%/err.o \
+	%D%/modules.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/main.o \
@@ -24,9 +48,5 @@ 
 
 noinst_PROGRAMS += %D%/run
 
-## Helper targets for running make from the top-level due to run's main.o.
-%D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %C%docdir = $(docdir)/%C%
 %C%doc_DATA = %D%/README.txt