[14/83] sim: frv: move libsim.a creation to top-level

Message ID 20230103075605.13606-15-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:54 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in     | 246 +++++++++++++++++++++++++++++---------------
 sim/frv/Makefile.in |  12 +--
 sim/frv/local.mk    |  47 +++++++++
 3 files changed, 209 insertions(+), 96 deletions(-)
  

Patch

diff --git a/sim/frv/Makefile.in b/sim/frv/Makefile.in
index a13765589da9..12af397f4c1e 100644
--- a/sim/frv/Makefile.in
+++ b/sim/frv/Makefile.in
@@ -17,17 +17,7 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-FRV_OBJS = frv.o cpu.o decode.o sem.o model.o mloop.o cgen-par.o
-
-SIM_OBJS = \
-	$(SIM_NEW_COMMON_OBJS) \
-	cgen-utils.o cgen-trace.o cgen-scache.o cgen-fpu.o cgen-accfp.o \
-	cgen-run.o \
-	sim-if.o arch.o \
-	$(FRV_OBJS) \
-	traps.o interrupts.o memory.o cache.o pipeline.o \
-	profile.o profile-fr400.o profile-fr450.o profile-fr500.o profile-fr550.o options.o \
-	reset.o registers.o
+SIM_LIBSIM =
 
 SIM_EXTRA_CFLAGS = @SIM_FRV_TRAPDUMP_FLAGS@
 
diff --git a/sim/frv/local.mk b/sim/frv/local.mk
index 471b0adc6533..2451235d2385 100644
--- a/sim/frv/local.mk
+++ b/sim/frv/local.mk
@@ -16,6 +16,53 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/modules.o \
+	\
+	%D%/cgen-accfp.o \
+	%D%/cgen-fpu.o \
+	%D%/cgen-run.o \
+	%D%/cgen-scache.o \
+	%D%/cgen-trace.o \
+	%D%/cgen-utils.o \
+	\
+	%D%/arch.o \
+	%D%/cgen-par.o \
+	%D%/cpu.o \
+	%D%/decode.o \
+	%D%/frv.o \
+	%D%/mloop.o \
+	%D%/model.o \
+	%D%/sem.o \
+	\
+	%D%/cache.o \
+	%D%/interrupts.o \
+	%D%/memory.o \
+	%D%/options.o \
+	%D%/pipeline.o \
+	%D%/profile.o \
+	%D%/profile-fr400.o \
+	%D%/profile-fr450.o \
+	%D%/profile-fr500.o \
+	%D%/profile-fr550.o \
+	%D%/registers.o \
+	%D%/reset.o \
+	%D%/sim-if.o \
+	%D%/traps.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \