[42/83] sim: bpf: move arch-specific file compilation to top-level

Message ID 20230103075605.13606-43-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  We can drop the arch-specific rules from the subdir as they're no
longer used.
---
 sim/Makefile.in     | 10 +++++++---
 sim/bpf/Makefile.in | 23 -----------------------
 sim/bpf/local.mk    | 11 ++++++++---
 3 files changed, 15 insertions(+), 29 deletions(-)
  

Patch

diff --git a/sim/bpf/Makefile.in b/sim/bpf/Makefile.in
index 64ec667c12c7..2376b859dd81 100644
--- a/sim/bpf/Makefile.in
+++ b/sim/bpf/Makefile.in
@@ -22,27 +22,4 @@  SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=64
 
 ## COMMON_POST_CONFIG_FRAG
 
-# Dependencies for binaries from CGEN generated source
-
-mloop-le.o: mloop-le.c
-	$(COMPILE) -DWANT_ISA_EBPFLE mloop-le.c
-	$(POSTCOMPILE)
-mloop-be.o: mloop-be.c
-	$(COMPILE) -DWANT_ISA_EBPFBE mloop-be.c
-	$(POSTCOMPILE)
-
-decode-le.o: decode-le.c
-	$(COMPILE) -DWANT_ISA_EBPFLE $(srcdir)/decode-le.c
-	$(POSTCOMPILE)
-decode-be.o: decode-be.c
-	$(COMPILE) -DWANT_ISA_EBPFBE $(srcdir)/decode-be.c
-	$(POSTCOMPILE)
-
-sem-le.o: sem-le.c
-	$(COMPILE) -DWANT_ISA_EBPFLE $(srcdir)/sem-le.c
-	$(POSTCOMPILE)
-sem-be.o: sem-be.c
-	$(COMPILE) -DWANT_ISA_EBPFBE $(srcdir)/sem-be.c
-	$(POSTCOMPILE)
-
 arch = bpf
diff --git a/sim/bpf/local.mk b/sim/bpf/local.mk
index 19dcc25736c1..580f744520c8 100644
--- a/sim/bpf/local.mk
+++ b/sim/bpf/local.mk
@@ -15,6 +15,14 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+AM_CPPFLAGS_%C% = -DWITH_TARGET_WORD_BITSIZE=64
+AM_CPPFLAGS_%C%_mloop_le.o = -DWANT_ISA_EBPFLE
+AM_CPPFLAGS_%C%_mloop_be.o = -DWANT_ISA_EBPFBE
+AM_CPPFLAGS_%C%_decode_le.o = -DWANT_ISA_EBPFLE
+AM_CPPFLAGS_%C%_decode_be.o = -DWANT_ISA_EBPFBE
+AM_CPPFLAGS_%C%_sem_le.o = -DWANT_ISA_EBPFLE
+AM_CPPFLAGS_%C%_sem_be.o = -DWANT_ISA_EBPFBE
+
 %C%_libsim_a_SOURCES =
 %C%_libsim_a_LIBADD = \
 	$(common_libcommon_a_OBJECTS) \
@@ -44,9 +52,6 @@  $(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
 
 noinst_LIBRARIES += %D%/libsim.a
 
-%D%/%.o: %D%/%.c
-	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 %D%/%.o: common/%.c
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)