[23/83] sim: microblaze: move libsim.a creation to top-level

Message ID 20230103075605.13606-24-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:55 a.m. UTC
  The objects are still compiled in the subdir, but the creation of the
archive itself is in the top-level.  This is a required step before we
can move compilation itself up, and makes it easier to review.

The downside is that each object compile is a recursive make instead of
a single one.  On my 4 core system, it adds ~100msec to the build per
port, so it's not great, but it shouldn't be a big deal.  This will go
away of course once the top-level compiles objects.
---
 sim/Makefile.in            | 140 +++++++++++++++++++++++--------------
 sim/microblaze/Makefile.in |   5 +-
 sim/microblaze/local.mk    |  18 +++++
 3 files changed, 106 insertions(+), 57 deletions(-)
  

Patch

diff --git a/sim/microblaze/Makefile.in b/sim/microblaze/Makefile.in
index 4f9272a554bf..502e8a44a73c 100644
--- a/sim/microblaze/Makefile.in
+++ b/sim/microblaze/Makefile.in
@@ -17,9 +17,6 @@ 
 
 ## COMMON_PRE_CONFIG_FRAG
 
-SIM_OBJS = \
-	interp.o \
-	$(SIM_NEW_COMMON_OBJS) \
-	sim-resume.o
+SIM_LIBSIM =
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/microblaze/local.mk b/sim/microblaze/local.mk
index c9fc789113e6..94abebc1dbbc 100644
--- a/sim/microblaze/local.mk
+++ b/sim/microblaze/local.mk
@@ -16,6 +16,24 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+%C%_libsim_a_SOURCES =
+%C%_libsim_a_LIBADD = \
+	$(common_libcommon_a_OBJECTS) \
+	%D%/interp.o \
+	$(patsubst %,%D%/%,$(SIM_NEW_COMMON_OBJS)) \
+	$(patsubst %,%D%/dv-%.o,$(SIM_HW_DEVICES)) \
+	%D%/modules.o \
+	%D%/sim-resume.o
+$(%C%_libsim_a_OBJECTS) $(%C%_libsim_a_LIBADD): %D%/hw-config.h
+
+noinst_LIBRARIES += %D%/libsim.a
+
+%D%/%.o: %D%/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
+%D%/%.o: common/%.c
+	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+
 %C%_run_SOURCES =
 %C%_run_LDADD = \
 	%D%/nrun.o \