[5/5] sim: v850: drop subdir configure logic

Message ID 20221107162426.26097-5-vapier@gentoo.org
State Committed
Headers
Series [1/5] sim: riscv: drop subdir configure logic |

Commit Message

Mike Frysinger Nov. 7, 2022, 4:24 p.m. UTC
  We've been using this only to set the default word size to 32.  We
can easily move this into the makefile via a -D compiler flag and
clean up the build logic quite a bit.
---
 sim/Makefile.in       |    4 +-
 sim/configure         |   26 +-
 sim/configure.ac      |    2 +-
 sim/v850/Makefile.in  |    2 +
 sim/v850/aclocal.m4   |   16 -
 sim/v850/configure    | 2932 -----------------------------------------
 sim/v850/configure.ac |    7 -
 7 files changed, 27 insertions(+), 2962 deletions(-)
 delete mode 100644 sim/v850/aclocal.m4
 delete mode 100755 sim/v850/configure
 delete mode 100644 sim/v850/configure.ac
  

Patch

diff --git a/sim/configure.ac b/sim/configure.ac
index cec89bb94812..675fa1bb44d6 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -155,7 +155,7 @@  if test "${enable_sim}" != no; then
     SIM_TARGET([rx-*-*], [rx])
     SIM_TARGET([sh*-*-*], [sh])
     SIM_TARGET([sparc-*-*], [erc32])
-    SIM_TARGET([v850*-*-*], [v850], [true], [sim_igen=yes])
+    SIM_TARGET([v850*-*-*], [v850], [], [sim_igen=yes])
   done
 
   if test "x${enable_example_sims}" = xyes; then
diff --git a/sim/v850/Makefile.in b/sim/v850/Makefile.in
index ec70b0bb15a5..c71ccf080e9b 100644
--- a/sim/v850/Makefile.in
+++ b/sim/v850/Makefile.in
@@ -23,4 +23,6 @@  SIM_OBJS = \
 	itable.o semantics.o idecode.o icache.o engine.o irun.o support.o \
 	sim-resume.o
 
+SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=32 -DWITH_TARGET_WORD_MSB=31
+
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/v850/configure.ac b/sim/v850/configure.ac
deleted file mode 100644
index 1fa7c0ef7c9f..000000000000
--- a/sim/v850/configure.ac
+++ /dev/null
@@ -1,7 +0,0 @@ 
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(Makefile.in)
-AC_CONFIG_MACRO_DIRS([../m4 ../.. ../../config])
-
-SIM_AC_OPTION_BITSIZE(32,31)
-
-SIM_AC_OUTPUT