[3/5] sim: or1k: drop subdir configure logic

Message ID 20221107162426.26097-3-vapier@gentoo.org
State Committed
Headers
Series [1/5] sim: riscv: drop subdir configure logic |

Commit Message

Mike Frysinger Nov. 7, 2022, 4:24 p.m. UTC
  We've been using this only to set the default word size to 32.  We
can easily move this into the makefile via a -D compiler flag and
clean up the build logic quite a bit.
---
 sim/Makefile.in       |   15 +-
 sim/configure         |   24 +-
 sim/configure.ac      |    2 +-
 sim/or1k/Makefile.in  |    2 +
 sim/or1k/aclocal.m4   |   16 -
 sim/or1k/configure    | 2932 -----------------------------------------
 sim/or1k/configure.ac |    7 -
 7 files changed, 32 insertions(+), 2966 deletions(-)
 delete mode 100644 sim/or1k/aclocal.m4
 delete mode 100755 sim/or1k/configure
 delete mode 100644 sim/or1k/configure.ac
  

Patch

diff --git a/sim/configure.ac b/sim/configure.ac
index c179e636a226..48bf75e88085 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -147,7 +147,7 @@  if test "${enable_sim}" != no; then
     SIM_TARGET([mn10300*-*-*], [mn10300], [true], [sim_igen=yes])
     SIM_TARGET([moxie-*-*], [moxie])
     SIM_TARGET([msp430*-*-*], [msp430])
-    SIM_TARGET([or1k*-*-*], [or1k], [true])
+    SIM_TARGET([or1k*-*-*], [or1k])
     SIM_TARGET([powerpc*-*-*], [ppc], [true])
     SIM_TARGET([pru*-*-*], [pru])
     SIM_TARGET([riscv*-*-*], [riscv])
diff --git a/sim/or1k/Makefile.in b/sim/or1k/Makefile.in
index fdf49835c7b8..17c40bcdc544 100644
--- a/sim/or1k/Makefile.in
+++ b/sim/or1k/Makefile.in
@@ -40,6 +40,8 @@  SIM_OBJS = \
 
 SIM_OBJS += $(OR1K_OBJS)
 
+SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=32 -DWITH_TARGET_WORD_MSB=31
+
 ## COMMON_POST_CONFIG_FRAG
 
 arch = or1k
diff --git a/sim/or1k/configure.ac b/sim/or1k/configure.ac
deleted file mode 100644
index a0fe51c897bc..000000000000
--- a/sim/or1k/configure.ac
+++ /dev/null
@@ -1,7 +0,0 @@ 
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(Makefile.in)
-AC_CONFIG_MACRO_DIRS([../m4 ../.. ../../config])
-
-SIM_AC_OPTION_BITSIZE([32], [31])
-
-SIM_AC_OUTPUT