[2/5] sim: bpf: drop subdir configure logic

Message ID 20221107162426.26097-2-vapier@gentoo.org
State Committed
Headers
Series [1/5] sim: riscv: drop subdir configure logic |

Commit Message

Mike Frysinger Nov. 7, 2022, 4:24 p.m. UTC
  We've been using this only to set the default word size to 64.  We
can easily move this into the makefile via a -D compiler flag and
clean up the build logic quite a bit.
---
 sim/Makefile.in      |   32 +-
 sim/bpf/Makefile.in  |    2 +
 sim/bpf/aclocal.m4   |   16 -
 sim/bpf/configure    | 2932 ------------------------------------------
 sim/bpf/configure.ac |    7 -
 sim/configure        |   32 +-
 sim/configure.ac     |    2 +-
 7 files changed, 44 insertions(+), 2979 deletions(-)
 delete mode 100644 sim/bpf/aclocal.m4
 delete mode 100755 sim/bpf/configure
 delete mode 100644 sim/bpf/configure.ac
  

Patch

diff --git a/sim/bpf/Makefile.in b/sim/bpf/Makefile.in
index 522484235357..3fa3b67f12d2 100644
--- a/sim/bpf/Makefile.in
+++ b/sim/bpf/Makefile.in
@@ -31,6 +31,8 @@  SIM_OBJS = \
 	$(BPF_GEN_OBJS) \
 	$(BPF_HAND_OBJS)
 
+SIM_EXTRA_CFLAGS = -DWITH_TARGET_WORD_BITSIZE=64
+
 SIM_EXTRA_CLEAN = bpf-clean
 
 ## COMMON_POST_CONFIG_FRAG
diff --git a/sim/bpf/configure.ac b/sim/bpf/configure.ac
deleted file mode 100644
index 87654ec6a919..000000000000
--- a/sim/bpf/configure.ac
+++ /dev/null
@@ -1,7 +0,0 @@ 
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(Makefile.in)
-AC_CONFIG_MACRO_DIRS([../m4 ../.. ../../config])
-
-SIM_AC_OPTION_BITSIZE([64])
-
-SIM_AC_OUTPUT
diff --git a/sim/configure.ac b/sim/configure.ac
index 97cea4b6dd8b..c179e636a226 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -129,7 +129,7 @@  if test "${enable_sim}" != no; then
     SIM_TARGET([arm*-*-*], [arm])
     SIM_TARGET([avr*-*-*], [avr])
     SIM_TARGET([bfin-*-*], [bfin])
-    SIM_TARGET([bpf-*-*], [bpf], [true])
+    SIM_TARGET([bpf-*-*], [bpf])
     SIM_TARGET([cr16*-*-*], [cr16])
     SIM_TARGET([cris-*-* | crisv32-*-*], [cris])
     SIM_TARGET([d10v-*-*], [d10v])