[04/17] sim: cris: fix -Wunused-but-set-variable warnings

Message ID 20231207035937.14920-4-vapier@gentoo.org
State New
Headers
Series [01/17] sim: arm: fix -Wunused-but-set-variable warnings |

Commit Message

Mike Frysinger Dec. 7, 2023, 3:59 a.m. UTC
  We suppress the warning in the generated switch file because the cris
cpu file has a hack to workaround a cgen bug, but that generates a set
but unused variable which makes the compiler upset.
---
 sim/Makefile.in   | 2 ++
 sim/cris/local.mk | 4 ++++
 sim/cris/sim-if.c | 7 +++----
 3 files changed, 9 insertions(+), 4 deletions(-)
  

Patch

diff --git a/sim/cris/local.mk b/sim/cris/local.mk
index 12fa86b410d2..66ebc99376c4 100644
--- a/sim/cris/local.mk
+++ b/sim/cris/local.mk
@@ -16,6 +16,10 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
+## Some CGEN kludges are causing build-time warnings.  See cris.cpu for details.
+AM_CFLAGS_%C%_mloopv10f.o = -Wno-unused-but-set-variable
+AM_CFLAGS_%C%_mloopv32f.o = -Wno-unused-but-set-variable
+
 nodist_%C%_libsim_a_SOURCES = \
 	%D%/modules.c
 %C%_libsim_a_SOURCES = \
diff --git a/sim/cris/sim-if.c b/sim/cris/sim-if.c
index cad71693ede9..12baafbf323d 100644
--- a/sim/cris/sim-if.c
+++ b/sim/cris/sim-if.c
@@ -337,7 +337,6 @@  cris_set_section_offset_iterator (bfd *abfd, asection *s, void *vp)
 static void
 cris_offset_sections (SIM_DESC sd, int offset)
 {
-  bfd_boolean ret;
   struct bfd *abfd = STATE_PROG_BFD (sd);
   asection *text;
   struct offsetinfo oi;
@@ -350,7 +349,7 @@  cris_offset_sections (SIM_DESC sd, int offset)
   oi.offset = offset;
 
   bfd_map_over_sections (abfd, cris_set_section_offset_iterator, &oi);
-  ret = bfd_set_start_address (abfd, bfd_get_start_address (abfd) + offset);
+  bfd_set_start_address (abfd, bfd_get_start_address (abfd) + offset);
 
   STATE_START_ADDR (sd) = bfd_get_start_address (abfd);
 }
@@ -516,7 +515,7 @@  cris_handle_interpreter (SIM_DESC sd, struct bfd *abfd)
   for (i = 0; i < n_hdrs; i++)
     {
       int interplen;
-      bfd_size_type interpsiz, interp_filesiz;
+      bfd_size_type interpsiz;
       struct progbounds interp_bounds;
 
       if (phdr[i].p_type != PT_INTERP)
@@ -563,7 +562,7 @@  cris_handle_interpreter (SIM_DESC sd, struct bfd *abfd)
 	 perhaps should.  */
       interp_load_addr = 0x40000;
       interpsiz = interp_bounds.endmem - interp_bounds.startmem;
-      interp_filesiz = interp_bounds.end_loadmem - interp_bounds.startmem;
+      /* interp_filesiz = interp_bounds.end_loadmem - interp_bounds.startmem; */
 
       /* If we have a non-DSO or interpreter starting at the wrong
 	 address, bail.  */