[03/15] Remove unused macro

Message ID 1403014378-4349-4-git-send-email-gbenson@redhat.com
State Committed
Headers

Commit Message

Gary Benson June 17, 2014, 2:12 p.m. UTC
  This commit removes an unused macro from i386-nat.c.

gdb/
2014-06-17  Gary Benson  <gbenson@redhat.com>

	* i386-nat.c (I386_DR_WATCH_MASK): Remove macro.
---
 gdb/ChangeLog  |    4 ++++
 gdb/i386-nat.c |    3 ---
 2 files changed, 4 insertions(+), 3 deletions(-)
  

Comments

Pedro Alves June 17, 2014, 3:35 p.m. UTC | #1
On 06/17/2014 03:12 PM, Gary Benson wrote:
> This commit removes an unused macro from i386-nat.c.
> 
> gdb/
> 2014-06-17  Gary Benson  <gbenson@redhat.com>
> 
> 	* i386-nat.c (I386_DR_WATCH_MASK): Remove macro.

I looked at the history.  Jan added it in a79d3c27d, and I
removed all uses in 1ced966e3.  It could still be used in I386_DR_WATCH_HIT,
like it was before 1ced966e3 -- not sure why I reverted that bit -- but
that wouldn't increase readability, IMO.

Thus, OK.  Please push.
  

Patch

diff --git a/gdb/i386-nat.c b/gdb/i386-nat.c
index 7c9e7ca..f9fb52f 100644
--- a/gdb/i386-nat.c
+++ b/gdb/i386-nat.c
@@ -143,9 +143,6 @@  struct i386_dr_low_type i386_dr_low;
   (((dr7) \
     >> (DR_CONTROL_SHIFT + DR_CONTROL_SIZE * (i))) & 0x0f)
 
-/* Mask that this I'th watchpoint has triggered.  */
-#define I386_DR_WATCH_MASK(i)	(1 << (i))
-
 /* Did the watchpoint whose address is in the I'th register break?  */
 #define I386_DR_WATCH_HIT(dr6, i) ((dr6) & (1 << (i)))