[PATCH/committed,5/5] sim: drop support for recursive makes entirely

Message ID 20240103062132.24338-5-vapier@gentoo.org
State New
Headers
Series [PATCH/committed,1/5] sim: ppc: move main.o compilation to top-level |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 3, 2024, 6:21 a.m. UTC
  Now that all ports have been merged to the top-level, we no longer need
this framework to pass settings down to sub-makefiles.  Delete it all.
---
 sim/Makefile.in       |  4 +--
 sim/arch-subdir.mk.in | 68 -------------------------------------------
 sim/configure         | 35 +---------------------
 sim/configure.ac      |  9 ++----
 4 files changed, 4 insertions(+), 112 deletions(-)
 delete mode 100644 sim/arch-subdir.mk.in
  

Patch

diff --git a/sim/arch-subdir.mk.in b/sim/arch-subdir.mk.in
deleted file mode 100644
index c3da955668a6..000000000000
--- a/sim/arch-subdir.mk.in
+++ /dev/null
@@ -1,68 +0,0 @@ 
-## Fragment to pass common settings into arch subdir builds.
-## NB: This should eventually be merged into sim/Makefile.am once there are no
-## subdir configure scripts.
-#
-#   Copyright (C) 1993-2023 Free Software Foundation, Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program.  If not, see <http://www.gnu.org/licenses/>.
-
-AM_V = @AM_V@
-
-EXEEXT = @EXEEXT@
-
-LN_S = @LN_S@
-
-CC = @CC@
-C_DIALECT = @C_DIALECT@
-CC_FOR_BUILD = @CC_FOR_BUILD@
-CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
-CPPFLAGS_FOR_BUILD = @CPPFLAGS_FOR_BUILD@
-CFLAGS = @CFLAGS@
-CPPFLAGS = @CPPFLAGS@
-LDFLAGS = @LDFLAGS@
-
-AR = @AR@
-AR_FLAGS = rc
-RANLIB = @RANLIB@
-
-LIBTOOL = @LIBTOOL@
-AM_V_lt = $(am__v_lt_@AM_V@)
-am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
-am__v_lt_0 = --silent
-am__v_lt_1 = 
-
-DEPMODE = @CCDEPMODE@
-DEPDIR = @DEPDIR@
-
-SDL_CFLAGS = @SDL_CFLAGS@
-TERMCAP_LIB = @TERMCAP_LIB@
-READLINE_LIB = @READLINE_LIB@
-READLINE_CFLAGS = @READLINE_CFLAGS@
-
-COMMON_LIBS = @LIBS@
-WARN_CFLAGS = @WARN_CFLAGS@
-WERROR_CFLAGS = @WERROR_CFLAGS@
-
-# Maintainer support, enable with --enable-maintainer-mode.
-# Once all subdirs are moved to automake, we can drop this custom logic and
-# switch back to using @MAINTAINER_MODE_TRUE@ directly.
-MAINT = ; @true
-# The following line is commented depending upon --enable-maintainer-mode.
-@MAINTAINER_MODE_TRUE@MAINT =
-
-SIM_INLINE = @SIM_INLINE@
-
-SIM_HW_CFLAGS = @SIM_HW_CFLAGS@
-
-PPC_IGEN_FLAGS = $(ppc_IGEN_FLAGS)
diff --git a/sim/configure.ac b/sim/configure.ac
index 0bb7f7d4b5f1..2a1b3a2f27d9 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -58,19 +58,14 @@  AC_SUBST(SIM_ENABLED_ARCHES)
 ENABLE_SIM=no
 dnl Build a particular arch subdir.
 dnl arg[1] is the arch subdir name.
-dnl arg[2] is whether the arch has a dedicated configure script.
 m4_define([SIM_BUILD_TARGET], [dnl
   ENABLE_SIM=yes
   AS_VAR_APPEND([SIM_ENABLED_ARCHES], [" $1"])
-  m4_if($2, [true], [dnl
-    AC_CONFIG_FILES($1/Makefile)
-  ])
   AC_CONFIG_FILES($1/.gdbinit:common/gdbinit.in)
 ])
 dnl Enable a particular arch subdir.
 dnl arg[1] is the matching target triple.
 dnl arg[2] is the arch subdir name.
-dnl arg[3] is whether the arch has a dedicated configure script.
 m4_define([SIM_TARGET], [dnl
   sim_enable_arch_$2=false
   case "${targ}" in
@@ -78,7 +73,7 @@  m4_define([SIM_TARGET], [dnl
       if test "${targ}" = "${target}"; then
         SIM_PRIMARY_TARGET=$2
       fi
-      SIM_BUILD_TARGET($2, $3)
+      SIM_BUILD_TARGET($2)
       sim_enable_arch_$2=true
       ;;
   esac
@@ -162,5 +157,5 @@  m4_include([ppc/acinclude.m4])
 m4_include([riscv/acinclude.m4])
 m4_include([rx/acinclude.m4])
 
-AC_CONFIG_FILES([arch-subdir.mk Makefile .gdbinit:gdbinit.in])
+AC_CONFIG_FILES([Makefile .gdbinit:gdbinit.in])
 AC_OUTPUT