[PATCH/committed,3/5] sim: drop support for automatic subdir recursion

Message ID 20240103062132.24338-3-vapier@gentoo.org
State New
Headers
Series [PATCH/committed,1/5] sim: ppc: move main.o compilation to top-level |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 3, 2024, 6:21 a.m. UTC
  No port relies on this anymore, so we can scrub it all.
---
 sim/Makefile.am  |  10 ---
 sim/Makefile.in  | 154 +++++++++++++----------------------------------
 sim/configure    |   8 +--
 sim/configure.ac |   3 -
 4 files changed, 44 insertions(+), 131 deletions(-)
  

Patch

diff --git a/sim/Makefile.am b/sim/Makefile.am
index b42926070dbd..9183b349725e 100644
--- a/sim/Makefile.am
+++ b/sim/Makefile.am
@@ -24,8 +24,6 @@  GNULIB_PARENT_DIR = ..
 srccom = $(srcdir)/common
 srcroot = $(srcdir)/..
 
-SUBDIRS = @subdirs@
-
 SIM_PRIMARY_TARGET = @SIM_PRIMARY_TARGET@
 
 ## We don't set some of these vars here, but we need to define them so they may
@@ -72,9 +70,6 @@  AM_CPPFLAGS_FOR_BUILD = \
 COMPILE_FOR_BUILD = $(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD)
 LINK_FOR_BUILD = $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@
 
-## Deps to add to the all-recursive target.  These are built before descending
-## into any subdirs.
-SIM_ALL_RECURSIVE_DEPS =
 ## Deps to add to the install-data-local target.
 SIM_INSTALL_DATA_LOCAL_DEPS =
 ## Deps to add to the install-exec-local target.
@@ -205,11 +200,6 @@  if SIM_ENABLE_ARCH_v850
 include v850/local.mk
 endif
 
-## Helper targets for running make from the top-level when some subdirs still
-## have Makefiles in subdirs.
-
-all-recursive: $(SIM_ALL_RECURSIVE_DEPS)
-
 install-data-local: installdirs $(SIM_INSTALL_DATA_LOCAL_DEPS)
 	$(AM_V_at)$(MKDIR_P) $(DESTDIR)$(libdir)
 	lib=`echo sim | sed '$(program_transform_name)'`; \
diff --git a/sim/configure.ac b/sim/configure.ac
index cd84040945b7..937571a9957d 100644
--- a/sim/configure.ac
+++ b/sim/configure.ac
@@ -86,9 +86,6 @@  m4_define([SIM_TARGET], [dnl
   AM_CONDITIONAL([SIM_ENABLE_ARCH_$2], [${sim_enable_arch_$2}])
 ])
 
-subdirs=""
-AC_SUBST(subdirs)
-
 dnl WHEN ADDING ENTRIES TO THIS MATRIX:
 dnl Make sure that the left side always has two dashes.  Otherwise you can get
 dnl spurious matches.  Even for unambiguous cases, do this as a convention, else