[PUSHED] gdb/testsuite: replace $testfile with $binfile in one case

Message ID dd82bbc1b3e79fb5e072ce4953cafc789333ce82.1690100780.git.aburgess@redhat.com
State Committed
Headers
Series [PUSHED] gdb/testsuite: replace $testfile with $binfile in one case |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-arm warning Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 warning Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_check--master-aarch64 warning Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_check--master-arm warning Patch failed to apply

Commit Message

Andrew Burgess July 23, 2023, 8:26 a.m. UTC
  For *reasons* I was hacking on gdb.base/foll-vfork.exp and wanted to
change the name of the binary that was created.  Should be easy, I
adjusted the global $binfile variable .... but that didn't work.

In one place the script uses $testfile instead of $binfile.

Fixed this to use $binfile, now I can easily change the name of the
generated binary, and the test still works.

There's no change in what is tested after this commit.
---
 gdb/testsuite/gdb.base/foll-vfork.exp | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 7f9e225fde0b769291abe843444b9c0820100f96
  

Patch

diff --git a/gdb/testsuite/gdb.base/foll-vfork.exp b/gdb/testsuite/gdb.base/foll-vfork.exp
index 13b8c3537a1..80b813d19b0 100644
--- a/gdb/testsuite/gdb.base/foll-vfork.exp
+++ b/gdb/testsuite/gdb.base/foll-vfork.exp
@@ -70,7 +70,7 @@  proc check_vfork_catchpoints {} {
   # Because setup_gdb uses 'return -code return' which would return to
   # our caller we need to wrap this call, spot when setup_gdb failed
   # (with return code 2), and then issue our own 'return -code return'.
-  set code [catch {setup_gdb $::testfile $::srcfile} string]
+  set code [catch {setup_gdb $::binfile $::srcfile} string]
   if { $code == 2 } {
     unsupported "vfork catchpoints"
     return -code return