[PATCH/committed,1/5] sim: ppc: move main.o compilation to top-level

Message ID 20240103062132.24338-1-vapier@gentoo.org
State New
Headers
Series [PATCH/committed,1/5] sim: ppc: move main.o compilation to top-level |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 3, 2024, 6:21 a.m. UTC
  ---
 sim/Makefile.in     | 27 +++++++++++++++++++--------
 sim/ppc/Makefile.in |  9 +--------
 sim/ppc/local.mk    | 19 +++++++++++++------
 3 files changed, 33 insertions(+), 22 deletions(-)
  

Patch

diff --git a/sim/ppc/Makefile.in b/sim/ppc/Makefile.in
index 68be55597497..7841e75d4ce8 100644
--- a/sim/ppc/Makefile.in
+++ b/sim/ppc/Makefile.in
@@ -100,7 +100,7 @@  BFD_LIB		= ../../bfd/libbfd.la
 
 TARGETLIB	= libsim.a
 
-all:	main.o $(TARGETLIB) $(GDB_OBJ)
+all:	$(TARGETLIB) $(GDB_OBJ)
 
 .c.o:
 	$(ECHO_CC) $(CC) -c $(STD_CFLAGS) $<
@@ -388,11 +388,6 @@  LIB_SRC = \
 	$(HW_SRC) \
 	$(LIB_INLINE_SRC)
 
-MAIN_SRC = \
-	main.c \
-	gdb-sim.c \
-	sim_calls.c
-
 COMMON_OBJS_NAMES = \
 	callback.o \
 	target-newlib-errno.o \
@@ -495,8 +490,6 @@  gdb-sim.o: gdb-sim.c $(PSIM_H)  $(OPTIONS_H) $(REGISTERS_H) $(GDB_REMOTE_SIM_H)
 
 spreg.o: spreg.c $(BASICS_H) $(SPREG_H)
 
-main.o: main.c $(PSIM_H) $(OPTIONS_H) $(DEVICE_H) $(EVENTS_H) $(BFD_H) $(GDB_CALLBACK_H) $(GDB_REMOTE_SIM_H)
-
 device.o: device.c $(DEVICE_TABLE_H) $(CAP_H) $(EVENTS_H) $(PSIM_H)
 
 tree.o: tree.c $(BASICS_H) $(DEVICE_H) $(TREE_H)
diff --git a/sim/ppc/local.mk b/sim/ppc/local.mk
index 155d83a9470a..3c36b60df5a4 100644
--- a/sim/ppc/local.mk
+++ b/sim/ppc/local.mk
@@ -15,9 +15,20 @@ 
 ## You should have received a copy of the GNU General Public License
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
-%C%_run_SOURCES =
+AM_CPPFLAGS_%C% = \
+	-DHAVE_COMMON_FPU \
+	$(sim_ppc_smp) \
+	$(sim_ppc_xor_endian) \
+	$(sim_ppc_bitsize) \
+	$(sim_ppc_timebase) \
+	$(sim_ppc_float) \
+	$(sim_ppc_monitor) \
+	$(sim_ppc_model) $(sim_ppc_default_model) $(sim_ppc_model_issue) \
+	$(sim_ppc_switch)
+
+%C%_run_SOURCES = \
+	%D%/main.c
 %C%_run_LDADD = \
-	%D%/main.o \
 	%D%/libsim.a \
 	$(SIM_COMMON_LIBS)
 
@@ -27,10 +38,6 @@  SIM_ALL_RECURSIVE_DEPS += common/libcommon.a
 %D%/libsim.a: common/libcommon.a
 	$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
 
-## Helper targets for running make from the top-level due to run's sis.o.
-%D%/main.o: %D%/%.o: %D%/%.c | %D%/libsim.a $(SIM_ALL_RECURSIVE_DEPS)
-	$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-
 noinst_PROGRAMS += %D%/run
 
 SIM_ALL_RECURSIVE_DEPS += %D%/defines.h