sim: use libtool to install programs

Message ID 20221105132920.27973-1-vapier@gentoo.org
State Committed
Headers
Series sim: use libtool to install programs |

Commit Message

Mike Frysinger Nov. 5, 2022, 1:29 p.m. UTC
  Now that we use libtool to link, we have to use it to install instead
of keeping the manual logic so we don't install wrapper shell scripts.
---
 sim/Makefile.am    | 3 ++-
 sim/Makefile.in    | 5 +++--
 sim/erc32/local.mk | 2 +-
 3 files changed, 6 insertions(+), 4 deletions(-)
  

Patch

diff --git a/sim/Makefile.am b/sim/Makefile.am
index 64847bc7abb3..fb28f98ece70 100644
--- a/sim/Makefile.am
+++ b/sim/Makefile.am
@@ -214,7 +214,8 @@  install-exec-local: installdirs $(SIM_INSTALL_EXEC_LOCAL_DEPS)
 		if [ -e $$d/run$(EXEEXT) ]; then \
 			n="$$run"; \
 			[ "$(SIM_PRIMARY_TARGET)" = "$$d" ] || n="$$n-$$d"; \
-			$(INSTALL_PROGRAM) $$d/run$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT) || exit 1; \
+			$(LIBTOOL) --mode=install \
+				$(INSTALL_PROGRAM) $$d/run$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT) || exit 1; \
 		fi; \
 	done
 
diff --git a/sim/erc32/local.mk b/sim/erc32/local.mk
index d73bc5b4bfef..1c6f7b3dbbd9 100644
--- a/sim/erc32/local.mk
+++ b/sim/erc32/local.mk
@@ -39,7 +39,7 @@  SIM_INSTALL_EXEC_LOCAL_DEPS += sim-%D-install-exec-local
 sim-%D-install-exec-local: installdirs
 	$(AM_V_at)$(MKDIR_P) $(DESTDIR)$(bindir)
 	n=`echo sis | sed '$(program_transform_name)'`; \
-	$(INSTALL_PROGRAM) %D%/sis$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT)
+	$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) %D%/run$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT)
 
 SIM_UNINSTALL_LOCAL_DEPS += sim-%D%-uninstall-local
 sim-%D%-uninstall-local: