sim: ppc: delete unused host bitsize settings

Message ID 20221105034527.32759-1-vapier@gentoo.org
State Committed
Headers
Series sim: ppc: delete unused host bitsize settings |

Commit Message

Mike Frysinger Nov. 5, 2022, 3:45 a.m. UTC
  Nothing checks this define anywhere, so drop all the logic.  We don't
want this to be a configure option in the first place as all such usage
should be automatic & following proper types.
---
 sim/ppc/configure    | 15 ---------------
 sim/ppc/configure.ac | 10 ----------
 sim/ppc/options.c    |  1 -
 sim/ppc/std-config.h |  8 ++------
 4 files changed, 2 insertions(+), 32 deletions(-)
  

Patch

diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index f26912eacde0..3054202dea20 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -214,16 +214,6 @@  if test x"$silent" != x"yes"; then
   echo "Setting hardware to $sim_hw_src, $sim_hw_obj"
 fi])dnl
 
-AC_ARG_ENABLE(sim-hostbitsize,
-[  --enable-sim-hostbitsize=32|64	Specify host bitsize (32 or 64).],
-[case "${enableval}" in
-  32|64) sim_hostbitsize="-DWITH_HOST_WORD_BITSIZE=$enableval";;
-  *)	 AC_MSG_ERROR("--enable-sim-hostbitsize was given $enableval.  Expected 32 or 64"); sim_hostbitsize="";;
-esac
-if test x"$silent" != x"yes" && test x"$sim_hostbitsize" != x""; then
-  echo "Setting hostbitsize flags = $sim_hostbitsize" 6>&1
-fi],[sim_hostbitsize=""])dnl
-
 
 AC_ARG_ENABLE(sim-icache,
 [  --enable-sim-icache=size		Specify instruction-decode cache size and type.],
diff --git a/sim/ppc/options.c b/sim/ppc/options.c
index b74451392b27..8e1c2629940a 100644
--- a/sim/ppc/options.c
+++ b/sim/ppc/options.c
@@ -114,7 +114,6 @@  print_options (void)
   printf_filtered ("WITH_TARGET_BYTE_ORDER   = %s\n", options_byte_order (WITH_TARGET_BYTE_ORDER));
   printf_filtered ("WITH_XOR_ENDIAN          = %d\n", WITH_XOR_ENDIAN);
   printf_filtered ("WITH_SMP                 = %d\n", WITH_SMP);
-  printf_filtered ("WITH_HOST_WORD_BITSIZE   = %d\n", WITH_HOST_WORD_BITSIZE);
   printf_filtered ("WITH_TARGET_WORD_BITSIZE = %d\n", WITH_TARGET_WORD_BITSIZE);
   printf_filtered ("WITH_ENVIRONMENT         = %s\n", options_env(WITH_ENVIRONMENT));
   printf_filtered ("WITH_EVENTS              = %d\n", WITH_EVENTS);
diff --git a/sim/ppc/std-config.h b/sim/ppc/std-config.h
index e02d5946a734..d317826ba1d4 100644
--- a/sim/ppc/std-config.h
+++ b/sim/ppc/std-config.h
@@ -79,9 +79,9 @@  extern enum bfd_endian current_target_byte_order;
 #endif
 
 
-/* Word size of host/target:
+/* Word size of target:
 
-   Set these according to your host and target requirements.  At this
+   Set these according to your target requirements.  At this
    point in time, I've only compiled (not run) for a 64bit and never
    built for a 64bit host.  This will always remain a compile time
    option */
@@ -90,10 +90,6 @@  extern enum bfd_endian current_target_byte_order;
 #define WITH_TARGET_WORD_BITSIZE        32 /* compiled only */
 #endif
 
-#ifndef WITH_HOST_WORD_BITSIZE
-#define WITH_HOST_WORD_BITSIZE		32 /* 64bit ready? */
-#endif
-
 
 /* Program environment: