sim: testsuite: improve parallel test processing

Message ID 20221023194722.23905-1-vapier@gentoo.org
State Committed
Headers
Series sim: testsuite: improve parallel test processing |

Commit Message

Mike Frysinger Oct. 23, 2022, 7:47 p.m. UTC
  The current logic limits itself to a maxdepth of 4 when looking for
results.  This wouldn't be a problem if cris didn't have a testsuite
at a depth of 5 which we end up ignoring when summarizing.  Rather
than bump the number from 4 to 5, rework the code so that we gather
the exact set of tests that we tried to run.
---
 sim/Makefile.in        | 9 +++++----
 sim/testsuite/local.mk | 9 +++++----
 2 files changed, 10 insertions(+), 8 deletions(-)
  

Patch

diff --git a/sim/testsuite/local.mk b/sim/testsuite/local.mk
index b8114a565997..cee51f24ae0f 100644
--- a/sim/testsuite/local.mk
+++ b/sim/testsuite/local.mk
@@ -50,13 +50,14 @@  check/%.exp:
 
 check-DEJAGNU-parallel:
 	$(AM_V_at)( \
-	$(MAKE) -k \
-	  `cd $(srcdir)/testsuite && find . -name '*.exp' -printf 'check/%P '`; \
+	set -- `cd $(srcdir)/testsuite && find . -name '*.exp' -printf '%P\n' | sed 's:[.]exp$$::'`; \
+	$(MAKE) -k `printf 'check/%s.exp ' $$@`; \
 	ret=$$?; \
+	set -- `printf 'testsuite/%s/ ' $$@`; \
 	$(SHELL) $(srcroot)/contrib/dg-extract-results.sh \
-	  `find testsuite/ -maxdepth 4 -name testrun.sum | sort` > testrun.sum; \
+	  `find $$@ -maxdepth 1 -name testrun.sum 2>/dev/null | sort` > testrun.sum; \
 	$(SHELL) $(srcroot)/contrib/dg-extract-results.sh -L \
-	  `find testsuite/ -maxdepth 4 -name testrun.log | sort` > testrun.log; \
+	  `find $$@ -maxdepth 1 -name testrun.log 2>/dev/null | sort` > testrun.log; \
 	echo; \
 	$(SED) -n '/^.*===.*Summary.*===/,$$p' testrun.sum; \
 	exit $$ret)