Fix comment in dwarf_decode_lines_1
Commit Message
When I read dwarf_decode_lines_1 comments today, it should be called
"special opcode" rather than "special operand", as said in DWARF spec.
It is obvious to me. I'll push it in if no comments in three days.
gdb:
2014-08-01 Yao Qi <yao@codesourcery.com>
* dwarf2read.c (dwarf_decode_lines_1): Replace "Special
operand" with "Special opcode" in comments.
---
gdb/dwarf2read.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
@@ -17241,7 +17241,8 @@ dwarf_decode_lines_1 (struct line_header *lh, const char *comp_dir,
if (op_code >= lh->opcode_base)
{
- /* Special operand. */
+ /* Special opcode. */
+
adj_opcode = op_code - lh->opcode_base;
address += (((op_index + (adj_opcode / lh->line_range))
/ lh->maximum_ops_per_instruction)