diff mbox series

powerpc64: Document binutils 2.29 requirement

Message ID 20210122013153.1354722-1-tuliom@linux.ibm.com
State Changes Requested
Delegated to: Adhemerval Zanella Netto
Headers show
Series powerpc64: Document binutils 2.29 requirement | expand

Commit Message

Tulio Magno Quites Machado Filho Jan. 22, 2021, 1:31 a.m. UTC
glibc has already been using POWER ISA 3.0b instructions (aka. POWER9)
in many places and already has this undocumented dependency.
---
 INSTALL             | 6 +++---
 manual/install.texi | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

Comments

Adhemerval Zanella Jan. 22, 2021, 5:05 p.m. UTC | #1
On 21/01/2021 22:31, Tulio Magno Quites Machado Filho via Libc-alpha wrote:
> glibc has already been using POWER ISA 3.0b instructions (aka. POWER9)
> in many places and already has this undocumented dependency.
> ---
>  INSTALL             | 6 +++---
>  manual/install.texi | 6 +++---
>  2 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/INSTALL b/INSTALL
> index de75e72760..f2e35da589 100644
> --- a/INSTALL
> +++ b/INSTALL
> @@ -506,9 +506,9 @@ build the GNU C Library:
>       moment.  As of release time, GNU 'binutils' 2.32 is the newest
>       verified to work to build the GNU C Library.
>  
> -     For PowerPC 64-bits little-endian (powerpc64le), 'objcopy' is
> -     required to support '--update-section'.  This option requires
> -     binutils 2.26 or newer.
> +     For PowerPC 64-bits little-endian (powerpc64le), 'as' is required
> +     to support all POWER ISA 3.0b instructions.  GNU 'binutils' 2.29 or
> +     later is known to work.
>  
>       ARC architecture needs 'binutils' 2.32 or higher for TLS related
>       fixes.
> diff --git a/manual/install.texi b/manual/install.texi
> index 8f26bb2a81..77e219e3d0 100644
> --- a/manual/install.texi
> +++ b/manual/install.texi
> @@ -545,9 +545,9 @@ No other assembler or linker has the necessary functionality at the
>  moment. As of release time, GNU @code{binutils} 2.32 is the newest
>  verified to work to build @theglibc{}.
>  
> -For PowerPC 64-bits little-endian (powerpc64le), @command{objcopy} is required
> -to support @option{--update-section}.  This option requires binutils 2.26 or
> -newer.
> +For PowerPC 64-bits little-endian (powerpc64le), @command{as} is required to
> +support all POWER ISA 3.0b instructions.  GNU @code{binutils} 2.29 or
> +later is known to work.
>  
>  ARC architecture needs @code{binutils} 2.32 or higher for TLS related fixes.

Please update sysdeps/powerpc/powerpc64/le/configure.ac as well.
diff mbox series

Patch

diff --git a/INSTALL b/INSTALL
index de75e72760..f2e35da589 100644
--- a/INSTALL
+++ b/INSTALL
@@ -506,9 +506,9 @@  build the GNU C Library:
      moment.  As of release time, GNU 'binutils' 2.32 is the newest
      verified to work to build the GNU C Library.
 
-     For PowerPC 64-bits little-endian (powerpc64le), 'objcopy' is
-     required to support '--update-section'.  This option requires
-     binutils 2.26 or newer.
+     For PowerPC 64-bits little-endian (powerpc64le), 'as' is required
+     to support all POWER ISA 3.0b instructions.  GNU 'binutils' 2.29 or
+     later is known to work.
 
      ARC architecture needs 'binutils' 2.32 or higher for TLS related
      fixes.
diff --git a/manual/install.texi b/manual/install.texi
index 8f26bb2a81..77e219e3d0 100644
--- a/manual/install.texi
+++ b/manual/install.texi
@@ -545,9 +545,9 @@  No other assembler or linker has the necessary functionality at the
 moment. As of release time, GNU @code{binutils} 2.32 is the newest
 verified to work to build @theglibc{}.
 
-For PowerPC 64-bits little-endian (powerpc64le), @command{objcopy} is required
-to support @option{--update-section}.  This option requires binutils 2.26 or
-newer.
+For PowerPC 64-bits little-endian (powerpc64le), @command{as} is required to
+support all POWER ISA 3.0b instructions.  GNU @code{binutils} 2.29 or
+later is known to work.
 
 ARC architecture needs @code{binutils} 2.32 or higher for TLS related fixes.