[PATCH/submitted,06/10] sim: ppc: move termios probes to top-level

Message ID 20240102053639.28290-6-vapier@gentoo.org
State New
Headers
Series [PATCH/submitted,01/10] sim: ppc: move long long test to top-level |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 2, 2024, 5:36 a.m. UTC
  This is the last compile-time logic in the ppc subdir.
---
 sim/config.h.in           |  12 +++
 sim/configure             | 138 ++++++++++++++++++++++++++-
 sim/m4/sim_ac_platform.m4 |  69 ++++++++++++++
 sim/ppc/config.in         |  12 ---
 sim/ppc/configure         | 192 --------------------------------------
 sim/ppc/configure.ac      |  69 --------------
 6 files changed, 217 insertions(+), 275 deletions(-)
  

Patch

diff --git a/sim/m4/sim_ac_platform.m4 b/sim/m4/sim_ac_platform.m4
index 6f3e48f63dd2..f523f03518bb 100644
--- a/sim/m4/sim_ac_platform.m4
+++ b/sim/m4/sim_ac_platform.m4
@@ -213,6 +213,75 @@  AS_IF([test x"$sim_cv_sysv_shm" = x"yes"], [dnl
   AC_DEFINE(HAVE_SYSV_SHM, 1, [Define if System V shared memory is supported])
 ])
 
+dnl Figure out what type of termio/termios support there is
+AC_CACHE_CHECK([for struct termios],
+  [sim_cv_termios_struct],
+  [AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/termios.h>], [
+  static struct termios x;
+  x.c_iflag = 0;
+  x.c_oflag = 0;
+  x.c_cflag = 0;
+  x.c_lflag = 0;
+  x.c_cc[NCCS] = 0;
+], [sim_cv_termios_struct="yes"], [sim_cv_termios_struct="no"])])
+if test $sim_cv_termios_struct = yes; then
+  AC_DEFINE([HAVE_TERMIOS_STRUCTURE], 1, [Define if struct termios exists.])
+fi
+
+if test "$sim_cv_termios_struct" = "yes"; then
+  AC_CACHE_VAL([sim_cv_termios_cline])
+  AC_CHECK_MEMBER(
+    [struct termios.c_line],
+    [sim_cv_termios_cline="yes"],
+    [sim_cv_termios_cline="no"], [
+#include <sys/types.h>
+#include <sys/termios.h>
+])
+  if test $sim_cv_termios_cline = yes; then
+    AC_DEFINE([HAVE_TERMIOS_CLINE], 1, [Define if struct termios has c_line.])
+  fi
+else
+  sim_cv_termios_cline=no
+fi
+
+if test "$sim_cv_termios_struct" != "yes"; then
+  AC_CACHE_CHECK([for struct termio],
+    [sim_cv_termio_struct],
+    [AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/termio.h>], [
+  static struct termio x;
+  x.c_iflag = 0;
+  x.c_oflag = 0;
+  x.c_cflag = 0;
+  x.c_lflag = 0;
+  x.c_cc[NCC] = 0;
+], [sim_cv_termio_struct="yes"], [sim_cv_termio_struct="no"])])
+  if test $sim_cv_termio_struct = yes; then
+    AC_DEFINE([HAVE_TERMIO_STRUCTURE], 1, [Define if struct termio exists.])
+  fi
+else
+  sim_cv_termio_struct=no
+fi
+
+if test "$sim_cv_termio_struct" = "yes"; then
+  AC_CACHE_VAL([sim_cv_termio_cline])
+  AC_CHECK_MEMBER(
+    [struct termio.c_line],
+    [sim_cv_termio_cline="yes"],
+    [sim_cv_termio_cline="no"], [
+#include <sys/types.h>
+#include <sys/termio.h>
+])
+  if test $sim_cv_termio_cline = yes; then
+    AC_DEFINE([HAVE_TERMIO_CLINE], 1, [Define if struct termio has c_line.])
+  fi
+else
+  sim_cv_termio_cline=no
+fi
+
 dnl Types used by common code
 AC_TYPE_GETGROUPS
 AC_TYPE_MODE_T
diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index 7b4b998e9487..b19be90ec33b 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -288,75 +288,6 @@  fi],[sim_xor_endian=""])dnl
 AC_CONFIG_HEADER(config.h:config.in)
 
 
-dnl Figure out what type of termio/termios support there is
-AC_CACHE_CHECK([for struct termios],
-  [sim_cv_termios_struct],
-  [AC_TRY_COMPILE([
-#include <sys/types.h>
-#include <sys/termios.h>], [
-  static struct termios x;
-  x.c_iflag = 0;
-  x.c_oflag = 0;
-  x.c_cflag = 0;
-  x.c_lflag = 0;
-  x.c_cc[NCCS] = 0;
-], [sim_cv_termios_struct="yes"], [sim_cv_termios_struct="no"])])
-if test $sim_cv_termios_struct = yes; then
-  AC_DEFINE([HAVE_TERMIOS_STRUCTURE], 1, [Define if struct termios exists.])
-fi
-
-if test "$sim_cv_termios_struct" = "yes"; then
-  AC_CACHE_VAL([sim_cv_termios_cline])
-  AC_CHECK_MEMBER(
-    [struct termios.c_line],
-    [sim_cv_termios_cline="yes"],
-    [sim_cv_termios_cline="no"], [
-#include <sys/types.h>
-#include <sys/termios.h>
-])
-  if test $sim_cv_termios_cline = yes; then
-    AC_DEFINE([HAVE_TERMIOS_CLINE], 1, [Define if struct termios has c_line.])
-  fi
-else
-  sim_cv_termios_cline=no
-fi
-
-if test "$sim_cv_termios_struct" != "yes"; then
-  AC_CACHE_CHECK([for struct termio],
-    [sim_cv_termio_struct],
-    [AC_TRY_COMPILE([
-#include <sys/types.h>
-#include <sys/termio.h>], [
-  static struct termio x;
-  x.c_iflag = 0;
-  x.c_oflag = 0;
-  x.c_cflag = 0;
-  x.c_lflag = 0;
-  x.c_cc[NCC] = 0;
-], [sim_cv_termio_struct="yes"], [sim_cv_termio_struct="no"])])
-  if test $sim_cv_termio_struct = yes; then
-    AC_DEFINE([HAVE_TERMIO_STRUCTURE], 1, [Define if struct termio exists.])
-  fi
-else
-  sim_cv_termio_struct=no
-fi
-
-if test "$sim_cv_termio_struct" = "yes"; then
-  AC_CACHE_VAL([sim_cv_termio_cline])
-  AC_CHECK_MEMBER(
-    [struct termio.c_line],
-    [sim_cv_termio_cline="yes"],
-    [sim_cv_termio_cline="no"], [
-#include <sys/types.h>
-#include <sys/termio.h>
-])
-  if test $sim_cv_termio_cline = yes; then
-    AC_DEFINE([HAVE_TERMIO_CLINE], 1, [Define if struct termio has c_line.])
-  fi
-else
-  sim_cv_termio_cline=no
-fi
-
 AC_SUBST(sim_line_nr)
 AC_SUBST(sim_opcode)
 AC_SUBST(sim_switch)