[PATCH/submitted,1/5] sim: ppc: fix bad AC_CACHE_CHECK call with semun

Message ID 20240102053026.20425-1-vapier@gentoo.org
State New
Headers
Series [PATCH/submitted,1/5] sim: ppc: fix bad AC_CACHE_CHECK call with semun |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 2, 2024, 5:30 a.m. UTC
  The first arg is the cache var name, and this one was typoed relative
to what the call actually set.  We also don't need the manual call to
AC_MSG_RESULT as the AC_CACHE_CHECK takes care of it for us.
---
 sim/ppc/configure    | 7 ++-----
 sim/ppc/configure.ac | 6 ++----
 2 files changed, 4 insertions(+), 9 deletions(-)
  

Patch

diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index adb4fc00a01d..1f61ff1bacef 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -97,16 +97,14 @@  esac
 ])dnl
 
 AC_CACHE_CHECK([if union semun defined],
-  ac_cv_HAS_UNION_SEMUN,
+  [ac_cv_has_union_semun],
   [AC_TRY_COMPILE([
 #include <sys/types.h>
 #include <sys/ipc.h>
 #include <sys/sem.h>],
 [union semun arg ;],
 [ac_cv_has_union_semun="yes"],
-[ac_cv_has_union_semun="no"])
-AC_MSG_RESULT($ac_cv_has_union_semun)
-])
+[ac_cv_has_union_semun="no"])])
 
 
 if test "$ac_cv_has_union_semun" = "yes"; then