[PATCH/committed] sim: ppc: drop build-config.h usage

Message ID 20240101212841.9239-1-vapier@gentoo.org
State New
Headers
Series [PATCH/committed] sim: ppc: drop build-config.h usage |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 fail Patch failed to apply
linaro-tcwg-bot/tcwg_gdb_build--master-arm fail Patch failed to apply

Commit Message

Mike Frysinger Jan. 1, 2024, 9:28 p.m. UTC
  This header is only used by the igen tool, and none of the igen code
depends on the configure-time checks.  Delete the logic to simplify
to prepare for moving it to the local.mk code.
---
 sim/ppc/configure    | 34 ----------------------------------
 sim/ppc/configure.ac | 31 -------------------------------
 sim/ppc/filter.c     |  2 --
 sim/ppc/igen.c       |  1 -
 sim/ppc/lf.c         |  1 -
 sim/ppc/misc.c       |  1 -
 sim/ppc/misc.h       |  2 --
 sim/ppc/table.c      |  1 -
 8 files changed, 73 deletions(-)
  

Patch

diff --git a/sim/ppc/configure.ac b/sim/ppc/configure.ac
index 290cdd15b819..adb4fc00a01d 100644
--- a/sim/ppc/configure.ac
+++ b/sim/ppc/configure.ac
@@ -480,37 +480,6 @@  fi
 
 AC_CHECK_TYPES(long long)
 
-# Since we run commands on the build system, we have to create a
-# separate config header for the build system if build != host.
-if test x$host = x$build; then
-  AC_CONFIG_COMMANDS([build-config.h],[cp config.h build-config.h])
-else
-  tempdir=build.$$
-  rm -rf $tempdir
-  mkdir $tempdir
-  cd $tempdir
-  case ${srcdir} in
-  /* | [A-Za-z]:[\\/]* ) realsrcdir=${srcdir};;
-  *) realsrcdir=../${srcdir};;
-  esac
-  saved_CFLAGS="${CFLAGS}"
-  # Put a plausible default for CC_FOR_BUILD in Makefile.
-  if test "x$cross_compiling" = "xno"; then
-    CC_FOR_BUILD='$(CC)'
-  else
-    CC_FOR_BUILD=gcc
-  fi
-  CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD-${CFLAGS}}" \
-  LDFLAGS="${LDFLAGS_FOR_BUILD}" \
-  ${realsrcdir}/configure \
-    --enable-languages=${enable_languages-all} \
-    --target=$target_alias --host=$build_alias --build=$build_alias
-  CFLAGS="${saved_CFLAGS}"
-  mv config.h ../build-config.h
-  cd ..
-  rm -rf $tempdir
-fi
-
 AC_SUBST(sim_line_nr)
 AC_SUBST(sim_opcode)
 AC_SUBST(sim_switch)
diff --git a/sim/ppc/filter.c b/sim/ppc/filter.c
index f1da310b1c24..c2f28ea7b898 100644
--- a/sim/ppc/filter.c
+++ b/sim/ppc/filter.c
@@ -20,8 +20,6 @@ 
 
 #include <stdio.h>
 
-#include "build-config.h"
-
 #include <string.h>
 
 #include "misc.h"
diff --git a/sim/ppc/igen.c b/sim/ppc/igen.c
index 9f642440541e..4de7469b4e36 100644
--- a/sim/ppc/igen.c
+++ b/sim/ppc/igen.c
@@ -23,7 +23,6 @@ 
 #include "misc.h"
 #include "lf.h"
 #include "table.h"
-#include "build-config.h"
 
 #include "filter.h"
 
diff --git a/sim/ppc/lf.c b/sim/ppc/lf.c
index e170a47b0902..9a9d6151c6e8 100644
--- a/sim/ppc/lf.c
+++ b/sim/ppc/lf.c
@@ -22,7 +22,6 @@ 
 #include <stdarg.h>
 #include <ctype.h>
 
-#include "build-config.h"
 #include "misc.h"
 #include "lf.h"
 
diff --git a/sim/ppc/misc.c b/sim/ppc/misc.c
index 8f2581e3ef32..a281d62b0af1 100644
--- a/sim/ppc/misc.c
+++ b/sim/ppc/misc.c
@@ -22,7 +22,6 @@ 
 #include <stdarg.h>
 #include <ctype.h>
 
-#include "build-config.h"
 #include "misc.h"
 
 #include <stdlib.h>
diff --git a/sim/ppc/misc.h b/sim/ppc/misc.h
index 08309134337d..a9e97a003e5b 100644
--- a/sim/ppc/misc.h
+++ b/sim/ppc/misc.h
@@ -20,8 +20,6 @@ 
 
 /* Frustrating header junk */
 
-#include "build-config.h"
-
 #include <stdio.h>
 #include <ctype.h>
 #include <string.h>
diff --git a/sim/ppc/table.c b/sim/ppc/table.c
index da1696759587..cb9a73aa8c49 100644
--- a/sim/ppc/table.c
+++ b/sim/ppc/table.c
@@ -24,7 +24,6 @@ 
 #include <fcntl.h>
 #include <ctype.h>
 
-#include "build-config.h"
 #include "misc.h"
 #include "lf.h"
 #include "table.h"