[2/6] Use vector in remote-fileio.c

Message ID 20231231-remote-fileio-v1-2-249cc6c440d9@tromey.com
State New
Headers
Series Make remote-fileio per-target |

Checks

Context Check Description
linaro-tcwg-bot/tcwg_gdb_build--master-aarch64 success Testing passed
linaro-tcwg-bot/tcwg_gdb_build--master-arm success Testing passed
linaro-tcwg-bot/tcwg_gdb_check--master-aarch64 success Testing passed
linaro-tcwg-bot/tcwg_gdb_check--master-arm success Testing passed

Commit Message

Tom Tromey Dec. 31, 2023, 8:25 p.m. UTC
  This changes remote_fio_data to be an object holding a vector.  This
simplifies the code somewhat.
---
 gdb/remote-fileio.c | 51 +++++++++++++++++----------------------------------
 1 file changed, 17 insertions(+), 34 deletions(-)
  

Comments

Lancelot SIX Jan. 1, 2024, 2:20 p.m. UTC | #1
Hi Tom,

I have a couple of comments below.

On Sun, Dec 31, 2023 at 01:25:39PM -0700, Tom Tromey wrote:
> This changes remote_fio_data to be an object holding a vector.  This
> simplifies the code somewhat.
> ---
>  gdb/remote-fileio.c | 51 +++++++++++++++++----------------------------------
>  1 file changed, 17 insertions(+), 34 deletions(-)
> 
> diff --git a/gdb/remote-fileio.c b/gdb/remote-fileio.c
> index 367edb54f74..4891b0c5b92 100644
> --- a/gdb/remote-fileio.c
> +++ b/gdb/remote-fileio.c
> @@ -37,9 +37,9 @@
>  #endif
>  #include <signal.h>
>  
> -static struct {
> -  int *fd_map;
> -  int fd_map_size;
> +static struct
> +{
> +  std::vector<int> fd_map;
>  } remote_fio_data;
>  
>  #define FIO_FD_INVALID		-1
> @@ -51,16 +51,13 @@ static int remote_fio_system_call_allowed = 0;
>  static int
>  remote_fileio_init_fd_map (void)
>  {
> -  int i;
> -
> -  if (!remote_fio_data.fd_map)
> +  if (remote_fio_data.fd_map.empty ())
>      {
> -      remote_fio_data.fd_map = XNEWVEC (int, 10);
> -      remote_fio_data.fd_map_size = 10;
> +      remote_fio_data.fd_map.resize (10);
>        remote_fio_data.fd_map[0] = FIO_FD_CONSOLE_IN;
>        remote_fio_data.fd_map[1] = FIO_FD_CONSOLE_OUT;
>        remote_fio_data.fd_map[2] = FIO_FD_CONSOLE_OUT;
> -      for (i = 3; i < 10; ++i)
> +      for (int i = 3; i < 10; ++i)
>  	remote_fio_data.fd_map[i] = FIO_FD_INVALID;

std::vector<T, Alloc>::resize has an overload which takes a value to use
for new elements of the vector.   This could be simplified as

    remote_fio_data.fd_map.resize (10, FIO_FD_INVALID);
    remote_fio_data.fd_map[0] = FIO_FD_CONSOLE_IN;
    remote_fio_data.fd_map[1] = FIO_FD_CONSOLE_OUT;
    remote_fio_data.fd_map[2] = FIO_FD_CONSOLE_OUT;

See below, but overall, I don’t really think we need to keep the "grow
by 10" strategy when using std::vector, this could simply be

    remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_IN)
    remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_OUT)
    remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_OUT)

>      }
>    return 3;
> @@ -69,25 +66,20 @@ remote_fileio_init_fd_map (void)
>  static int
>  remote_fileio_resize_fd_map (void)
>  {
> -  int i = remote_fio_data.fd_map_size;
> -
> -  if (!remote_fio_data.fd_map)
> +  if (remote_fio_data.fd_map.empty ())
>      return remote_fileio_init_fd_map ();
> -  remote_fio_data.fd_map_size += 10;
> -  remote_fio_data.fd_map =
> -    (int *) xrealloc (remote_fio_data.fd_map,
> -		      remote_fio_data.fd_map_size * sizeof (int));
> -  for (; i < remote_fio_data.fd_map_size; i++)
> +
> +  int i = remote_fio_data.fd_map.size ();
> +  remote_fio_data.fd_map.resize (i + 10);
> +  for (; i < remote_fio_data.fd_map.size (); i++)
>      remote_fio_data.fd_map[i] = FIO_FD_INVALID;

Similarly, if you keep the "grow by 10" strategy this could be

     remote_fio_data.fd_map.resize (i + 10, FIO_FD_INVALID);

> -  return remote_fio_data.fd_map_size - 10;
> +  return remote_fio_data.fd_map.size () - 10;
>  }
>  
>  static int
>  remote_fileio_next_free_fd (void)
>  {
> -  int i;
> -
> -  for (i = 0; i < remote_fio_data.fd_map_size; ++i)
> +  for (int i = 0; i < remote_fio_data.fd_map.size (); ++i)
>      if (remote_fio_data.fd_map[i] == FIO_FD_INVALID)
>        return i;

I think that’s mostly a personal preference thing, but std::find could
be used instead of an explicit loop

    auto it = std::find (remote_fio_data.fd_map.begin (),
                         remote_fio_data.fd_map.end (),
    		         FIO_FD_INVALID);
    if (it != remote_fio_data.fd_map.end ())
      return std::distance (remote_fio_data.fd_map.begin (), it);
    return remote_fileio_resize_fd_map ();

I think it could be possible to go one step further and remove
remote_fileio_resize_fd_map entirely.  The "grow by 10" strategy is not
necessary anymore if you use a std::vector.  A similar allocation
strategies comes for free.

    static int
    remote_fileio_next_free_fd ()
    {
        auto it = std::find (remote_fio_data.fd_map.begin (),
                             remote_fio_data.fd_map.end (),
        		         FIO_FD_INVALID);
        if (it != remote_fio_data.fd_map.end ())
          return std::ditance (remote_fio_data.fd_map.begin (), it);

        remote_fio_data.fd_map.emplace_back (FIO_FD_INVALID);
	return remote_fio_data.fd_map.size () - 1;
    }

One could also inline this inside remote_fileio_map_fd, and directly set
the appropriate FD value instead of using FIO_FD_INVALID temporarily.
But I would be happy keeping things this way for readability.

Best,
Lancelot.

>    return remote_fileio_resize_fd_map ();
> @@ -106,7 +98,7 @@ static int
>  remote_fileio_map_fd (int target_fd)
>  {
>    remote_fileio_init_fd_map ();
> -  if (target_fd < 0 || target_fd >= remote_fio_data.fd_map_size)
> +  if (target_fd < 0 || target_fd >= remote_fio_data.fd_map.size ())
>      return FIO_FD_INVALID;
>    return remote_fio_data.fd_map[target_fd];
>  }
> @@ -115,7 +107,7 @@ static void
>  remote_fileio_close_target_fd (int target_fd)
>  {
>    remote_fileio_init_fd_map ();
> -  if (target_fd >= 0 && target_fd < remote_fio_data.fd_map_size)
> +  if (target_fd >= 0 && target_fd < remote_fio_data.fd_map.size ())
>      remote_fio_data.fd_map[target_fd] = FIO_FD_INVALID;
>  }
>  
> @@ -1147,21 +1139,12 @@ do_remote_fileio_request (remote_target *remote, char *buf)
>  void
>  remote_fileio_reset (void)
>  {
> -  int ix;
> -
> -  for (ix = 0; ix != remote_fio_data.fd_map_size; ix++)
> +  for (int fd : remote_fio_data.fd_map)
>      {
> -      int fd = remote_fio_data.fd_map[ix];
> -
>        if (fd >= 0)
>  	close (fd);
>      }
> -  if (remote_fio_data.fd_map)
> -    {
> -      xfree (remote_fio_data.fd_map);
> -      remote_fio_data.fd_map = NULL;
> -      remote_fio_data.fd_map_size = 0;
> -    }
> +  remote_fio_data.fd_map.clear ();
>  }
>  
>  /* Handle a file I/O request.  BUF points to the packet containing the
> 
> -- 
> 2.43.0
>
  
Simon Marchi Jan. 1, 2024, 6:39 p.m. UTC | #2
On 2024-01-01 09:20, Lancelot SIX wrote:
> Hi Tom,
> 
> I have a couple of comments below.
> 
> On Sun, Dec 31, 2023 at 01:25:39PM -0700, Tom Tromey wrote:
>> This changes remote_fio_data to be an object holding a vector.  This
>> simplifies the code somewhat.
>> ---
>>  gdb/remote-fileio.c | 51 +++++++++++++++++----------------------------------
>>  1 file changed, 17 insertions(+), 34 deletions(-)
>>
>> diff --git a/gdb/remote-fileio.c b/gdb/remote-fileio.c
>> index 367edb54f74..4891b0c5b92 100644
>> --- a/gdb/remote-fileio.c
>> +++ b/gdb/remote-fileio.c
>> @@ -37,9 +37,9 @@
>>  #endif
>>  #include <signal.h>
>>  
>> -static struct {
>> -  int *fd_map;
>> -  int fd_map_size;
>> +static struct
>> +{
>> +  std::vector<int> fd_map;
>>  } remote_fio_data;
>>  
>>  #define FIO_FD_INVALID		-1
>> @@ -51,16 +51,13 @@ static int remote_fio_system_call_allowed = 0;
>>  static int
>>  remote_fileio_init_fd_map (void)
>>  {
>> -  int i;
>> -
>> -  if (!remote_fio_data.fd_map)
>> +  if (remote_fio_data.fd_map.empty ())
>>      {
>> -      remote_fio_data.fd_map = XNEWVEC (int, 10);
>> -      remote_fio_data.fd_map_size = 10;
>> +      remote_fio_data.fd_map.resize (10);
>>        remote_fio_data.fd_map[0] = FIO_FD_CONSOLE_IN;
>>        remote_fio_data.fd_map[1] = FIO_FD_CONSOLE_OUT;
>>        remote_fio_data.fd_map[2] = FIO_FD_CONSOLE_OUT;
>> -      for (i = 3; i < 10; ++i)
>> +      for (int i = 3; i < 10; ++i)
>>  	remote_fio_data.fd_map[i] = FIO_FD_INVALID;
> 
> std::vector<T, Alloc>::resize has an overload which takes a value to use
> for new elements of the vector.   This could be simplified as
> 
>     remote_fio_data.fd_map.resize (10, FIO_FD_INVALID);
>     remote_fio_data.fd_map[0] = FIO_FD_CONSOLE_IN;
>     remote_fio_data.fd_map[1] = FIO_FD_CONSOLE_OUT;
>     remote_fio_data.fd_map[2] = FIO_FD_CONSOLE_OUT;
> 
> See below, but overall, I don’t really think we need to keep the "grow
> by 10" strategy when using std::vector, this could simply be
> 
>     remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_IN)
>     remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_OUT)
>     remote_fio_data.fd_map.emplace_back (FIO_FD_CONSOLE_OUT)

I agree with Lancelot.  And from what I saw after quickly skimming the
code, remote_fileio_resize_fd_map and remote_fileio_next_free_fd could
be removed, since they callers can use simple vector operations.

Simon
  

Patch

diff --git a/gdb/remote-fileio.c b/gdb/remote-fileio.c
index 367edb54f74..4891b0c5b92 100644
--- a/gdb/remote-fileio.c
+++ b/gdb/remote-fileio.c
@@ -37,9 +37,9 @@ 
 #endif
 #include <signal.h>
 
-static struct {
-  int *fd_map;
-  int fd_map_size;
+static struct
+{
+  std::vector<int> fd_map;
 } remote_fio_data;
 
 #define FIO_FD_INVALID		-1
@@ -51,16 +51,13 @@  static int remote_fio_system_call_allowed = 0;
 static int
 remote_fileio_init_fd_map (void)
 {
-  int i;
-
-  if (!remote_fio_data.fd_map)
+  if (remote_fio_data.fd_map.empty ())
     {
-      remote_fio_data.fd_map = XNEWVEC (int, 10);
-      remote_fio_data.fd_map_size = 10;
+      remote_fio_data.fd_map.resize (10);
       remote_fio_data.fd_map[0] = FIO_FD_CONSOLE_IN;
       remote_fio_data.fd_map[1] = FIO_FD_CONSOLE_OUT;
       remote_fio_data.fd_map[2] = FIO_FD_CONSOLE_OUT;
-      for (i = 3; i < 10; ++i)
+      for (int i = 3; i < 10; ++i)
 	remote_fio_data.fd_map[i] = FIO_FD_INVALID;
     }
   return 3;
@@ -69,25 +66,20 @@  remote_fileio_init_fd_map (void)
 static int
 remote_fileio_resize_fd_map (void)
 {
-  int i = remote_fio_data.fd_map_size;
-
-  if (!remote_fio_data.fd_map)
+  if (remote_fio_data.fd_map.empty ())
     return remote_fileio_init_fd_map ();
-  remote_fio_data.fd_map_size += 10;
-  remote_fio_data.fd_map =
-    (int *) xrealloc (remote_fio_data.fd_map,
-		      remote_fio_data.fd_map_size * sizeof (int));
-  for (; i < remote_fio_data.fd_map_size; i++)
+
+  int i = remote_fio_data.fd_map.size ();
+  remote_fio_data.fd_map.resize (i + 10);
+  for (; i < remote_fio_data.fd_map.size (); i++)
     remote_fio_data.fd_map[i] = FIO_FD_INVALID;
-  return remote_fio_data.fd_map_size - 10;
+  return remote_fio_data.fd_map.size () - 10;
 }
 
 static int
 remote_fileio_next_free_fd (void)
 {
-  int i;
-
-  for (i = 0; i < remote_fio_data.fd_map_size; ++i)
+  for (int i = 0; i < remote_fio_data.fd_map.size (); ++i)
     if (remote_fio_data.fd_map[i] == FIO_FD_INVALID)
       return i;
   return remote_fileio_resize_fd_map ();
@@ -106,7 +98,7 @@  static int
 remote_fileio_map_fd (int target_fd)
 {
   remote_fileio_init_fd_map ();
-  if (target_fd < 0 || target_fd >= remote_fio_data.fd_map_size)
+  if (target_fd < 0 || target_fd >= remote_fio_data.fd_map.size ())
     return FIO_FD_INVALID;
   return remote_fio_data.fd_map[target_fd];
 }
@@ -115,7 +107,7 @@  static void
 remote_fileio_close_target_fd (int target_fd)
 {
   remote_fileio_init_fd_map ();
-  if (target_fd >= 0 && target_fd < remote_fio_data.fd_map_size)
+  if (target_fd >= 0 && target_fd < remote_fio_data.fd_map.size ())
     remote_fio_data.fd_map[target_fd] = FIO_FD_INVALID;
 }
 
@@ -1147,21 +1139,12 @@  do_remote_fileio_request (remote_target *remote, char *buf)
 void
 remote_fileio_reset (void)
 {
-  int ix;
-
-  for (ix = 0; ix != remote_fio_data.fd_map_size; ix++)
+  for (int fd : remote_fio_data.fd_map)
     {
-      int fd = remote_fio_data.fd_map[ix];
-
       if (fd >= 0)
 	close (fd);
     }
-  if (remote_fio_data.fd_map)
-    {
-      xfree (remote_fio_data.fd_map);
-      remote_fio_data.fd_map = NULL;
-      remote_fio_data.fd_map_size = 0;
-    }
+  remote_fio_data.fd_map.clear ();
 }
 
 /* Handle a file I/O request.  BUF points to the packet containing the