[82/83] sim: common: simplify modules.c deps

Message ID 20230103075605.13606-83-vapier@gentoo.org
State Committed
Headers
Series sim: merge subdir makefiles into top-level |

Commit Message

Mike Frysinger Jan. 3, 2023, 7:56 a.m. UTC
  Now that all ports (other than ppc) build in the top-level, we don't
need to expand all the modules.c targets as a recursive dep.  Each
port depends on their respective file now, and the ppc port doesn't
use it at all.
---
 sim/Makefile.in     | 9 ++++-----
 sim/common/local.mk | 6 ++----
 2 files changed, 6 insertions(+), 9 deletions(-)
  

Patch

diff --git a/sim/common/local.mk b/sim/common/local.mk
index 5905266dd80b..4a609ba5f8c9 100644
--- a/sim/common/local.mk
+++ b/sim/common/local.mk
@@ -161,10 +161,8 @@  GEN_MODULES_C_SRCS = \
 .PRECIOUS: %/stamp-modules
 
 ## NB: The ppc port doesn't currently utilize the modules API, so skip it.
-%C%_GEN_MODULES_C_TARGETS = $(patsubst %,%/modules.c,$(filter-out ppc,$(SIM_ENABLED_ARCHES)))
-MOSTLYCLEANFILES += $(%C%_GEN_MODULES_C_TARGETS) $(patsubst %,%/stamp-modules,$(SIM_ENABLED_ARCHES))
-## TODO: Drop this once each port's local.mk:libsim.a depends on it themself.
-SIM_ALL_RECURSIVE_DEPS += $(%C%_GEN_MODULES_C_TARGETS)
+%C%_GEN_MODULES_C_TARGETS = $(SIM_ENABLED_ARCHES:%=%/modules.c)
+MOSTLYCLEANFILES += $(%C%_GEN_MODULES_C_TARGETS) $(SIM_ENABLED_ARCHES:%=%/stamp-modules)
 
 LIBIBERTY_LIB = ../libiberty/libiberty.a
 BFD_LIB = ../bfd/libbfd.la