[1/4] sim: d10v: use common configure options

Message ID 1427696554-17585-1-git-send-email-vapier@gentoo.org
State Committed
Headers

Commit Message

Mike Frysinger March 30, 2015, 6:22 a.m. UTC
  In preparation for converting to nrun, call the common functions that
are needed.  This doesn't produce any new warnings, and the generated
code should be the same.

Committed.
---
 sim/d10v/ChangeLog    |   9 ++
 sim/d10v/Makefile.in  |   5 -
 sim/d10v/config.in    |  15 ++
 sim/d10v/configure    | 417 +++++++++++++++++++++++++++++++++++++++++++++++++-
 sim/d10v/configure.ac |   5 +
 sim/d10v/interp.c     |   8 +
 6 files changed, 452 insertions(+), 7 deletions(-)
  

Patch

diff --git a/sim/d10v/ChangeLog b/sim/d10v/ChangeLog
index 8bb2666..1ab3014 100644
--- a/sim/d10v/ChangeLog
+++ b/sim/d10v/ChangeLog
@@ -1,3 +1,12 @@ 
+2015-03-30  Mike Frysinger  <vapier@gentoo.org>
+
+	* Makefile.in (interp.o, simops.o, endian.o, table.o): Delete rules.
+	* configure.ac: Call SIM_AC_OPTION_ENDIAN, SIM_AC_OPTION_ALIGNMENT,
+	SIM_AC_OPTION_HOSTENDIAN, SIM_AC_OPTION_ENVIRONMENT, and
+	SIM_AC_OPTION_INLINE.
+	* config.in, configure: Regenerate.
+	* interp.c (sim_trace): Define.
+
 2015-03-16  Mike Frysinger  <vapier@gentoo.org>
 
 	* config.in, configure: Regenerate.
diff --git a/sim/d10v/Makefile.in b/sim/d10v/Makefile.in
index 173fe95..b6d6a18 100644
--- a/sim/d10v/Makefile.in
+++ b/sim/d10v/Makefile.in
@@ -50,8 +50,3 @@  gencode: gencode.o d10v-opc.o
 
 clean-extra:
 	rm -f table.c simops.h gencode
-
-interp.o: interp.c table.c $(INCLUDE)
-simops.o: simops.c simops.h $(INCLUDE)
-endian.o: endian.c $(INCLUDE)
-table.o: table.c
diff --git a/sim/d10v/config.in b/sim/d10v/config.in
index 5ded703..6003e58 100644
diff --git a/sim/d10v/configure b/sim/d10v/configure
index c7e82ec..af6e579 100755
diff --git a/sim/d10v/configure.ac b/sim/d10v/configure.ac
index 0daa1af..96d0ffd 100644
--- a/sim/d10v/configure.ac
+++ b/sim/d10v/configure.ac
@@ -5,6 +5,11 @@  sinclude(../common/acinclude.m4)
 
 SIM_AC_COMMON
 
+SIM_AC_OPTION_ENDIAN
+SIM_AC_OPTION_ALIGNMENT(STRICT_ALIGNMENT,STRICT_ALIGNMENT)
+SIM_AC_OPTION_HOSTENDIAN
+SIM_AC_OPTION_ENVIRONMENT
+SIM_AC_OPTION_INLINE
 SIM_AC_OPTION_WARNINGS
 
 SIM_AC_OUTPUT
diff --git a/sim/d10v/interp.c b/sim/d10v/interp.c
index 86b5e5e..27ae19f 100644
--- a/sim/d10v/interp.c
+++ b/sim/d10v/interp.c
@@ -1268,6 +1268,14 @@  sim_set_callbacks (p)
   d10v_callback = p;
 }
 
+int
+sim_trace (SIM_DESC sd)
+{
+  sim_resume (sd, 0, 0);
+
+  return 1;
+}
+
 void
 sim_stop_reason (sd, reason, sigrc)
      SIM_DESC sd;