Patchwork [pushed] Update README

login
register
mail settings
Submitter Simon Marchi (Code Review)
Date Nov. 15, 2019, 12:48 a.m.
Message ID <20191115004807.1E23220AF6@gnutoolchain-gerrit.osci.io>
Download mbox | patch
Permalink /patch/35930/
State New
Headers show

Comments

Simon Marchi (Code Review) - Nov. 15, 2019, 12:48 a.m.
The original change was created by Christian Biesinger.

Change URL: https://gnutoolchain-gerrit.osci.io/r/c/binutils-gdb/+/612
......................................................................

Update README

Adds descriptions for some recent-ish configure options to README.

Also updates the minimum Python version per commit
6c28e44a359e9f6cf455ddff0009ca99406f7224.

2019-11-14  Christian Biesinger  <cbiesinger@google.com>

	* README (`configure' options): Update.

Change-Id: I8ce8ca6935afbd130295e143802c585cf1e735f9
---
M gdb/ChangeLog
M gdb/README
2 files changed, 24 insertions(+), 1 deletion(-)

Patch

diff --git a/gdb/ChangeLog b/gdb/ChangeLog
index 1a84242..134c883 100644
--- a/gdb/ChangeLog
+++ b/gdb/ChangeLog
@@ -1,3 +1,7 @@ 
+2019-11-14  Christian Biesinger  <cbiesinger@google.com>
+
+	* README (`configure' options): Update.
+
 2019-11-14  Tom Tromey  <tromey@adacore.com>
 
 	* eval.c (evaluate_subexp_standard) <BINOP_ASSIGN>: Do not pass an
diff --git a/gdb/README b/gdb/README
index 8883a8a..be7fdcb 100644
--- a/gdb/README
+++ b/gdb/README
@@ -492,7 +492,7 @@ 
      GDB scripting much more powerful than the restricted CLI
      scripting language.  If your host does not have Python installed,
      you can find it on `http://www.python.org/download/'.  The oldest
-     version of Python supported by GDB is 2.4.  The optional argument
+     version of Python supported by GDB is 2.6.  The optional argument
      PYTHON is used to find the Python headers and libraries.  It can
      be either the name of a Python executable, or the name of the
      directory in which Python is installed.
@@ -507,6 +507,16 @@ 
      `pkg-config' executable, which will be queried to find the
      information needed to compile and link against Guile.
 
+`--enable-source-highlight'
+     When printing source code, use source highlighting.  This requires
+     libsource-highlight to be installed and is enabled by default
+     if the library is found.
+
+`--with-xxhash'
+     Use libxxhash for hashing.  This has no user-visible effect but
+     speeds up various GDB operations such as symbol loading.  Enabled
+     by default if libxxhash is found.
+
 `--without-included-regex'
      Don't use the regex library included with GDB (as part of the
      libiberty library).  This is the default on hosts with version 2
@@ -528,6 +538,15 @@ 
      after being built, the location of the system-wide init file will
      be adjusted accordingly. 
 
+`--with-system-gdbinit-dir=DIR'
+     Configure GDB to automatically load system-wide init files from
+     a directory. Files with extensions `.gdb', `.py' (if Python
+     support is enabled) and `.scm' (if Guile support is enabled) are
+     supported.  DIR should be an absolute directory name.  If DIR is
+     in a directory under the configured prefix, and GDB is moved to
+     another location after being built, the location of the system-
+     wide init directory will be adjusted accordingly.
+
 `--enable-build-warnings'
      When building the GDB sources, ask the compiler to warn about any
      code which looks even vaguely suspicious.  It passes many