libgloss: add per-file & per-dir flag support

Message ID 20231230015630.23441-1-vapier@gentoo.org
State New
Headers
Series libgloss: add per-file & per-dir flag support |

Commit Message

Mike Frysinger Dec. 30, 2023, 1:56 a.m. UTC
  This logic is copied from what's used in newlib today.  This allows
subdirs to easily define per-directory flags & per-file flags without
having to setup unique automake rules for each one.
---
 libgloss/Makefile.am | 6 +++++-
 libgloss/Makefile.in | 7 ++++++-
 2 files changed, 11 insertions(+), 2 deletions(-)
  

Patch

diff --git a/libgloss/Makefile.am b/libgloss/Makefile.am
index f74f515adba2..982b9e77e712 100644
--- a/libgloss/Makefile.am
+++ b/libgloss/Makefile.am
@@ -24,7 +24,11 @@  includetool_DATA =
 includesystooldir = $(tooldir)/include/sys
 includesystool_DATA =
 
-AM_CPPFLAGS = -idirafter $(srcroot)/include
+# These are useful for standalone object files like crt0.o.
+AM_CFLAGS = $(AM_CFLAGS_$(subst /,_,$(@D))) $(AM_CFLAGS_$(subst /,_,$(@D)_$(<F)))
+AM_CCASFLAGS = $(AM_CCASFLAGS_$(subst /,_,$(@D))) $(AM_CCASFLAGS_$(subst /,_,$(@D)_$(<F)))
+AM_CPPFLAGS = $(AM_CPPFLAGS_$(subst /,_,$(@D))) $(AM_CPPFLAGS_$(subst /,_,$(@D)_$(<F))) -idirafter $(srcroot)/include
+AM_LDFLAGS = $(AM_LDFLAGS_$(subst /,_,$(@D))) $(AM_LDFLAGS_$(subst -,_,$(subst /,_,$(@D)_$(@F))))
 
 # A fake library so automake will generate rules for plain objects that we want
 # to install (e.g. our crt0.o objects).