libgloss: sparc: add missing m4 include
Commit Message
Commit 8d758283785042589e95c93d7899cecf28ef00ea ("libgloss: merge
sparc configure script up a level") missed including the sparc
acinclude.m4 file which meant none of the sparc-specific vars were
propagating to the sub-makefile.
---
libgloss/Makefile.in | 8 +++++++-
libgloss/configure | 20 ++++++++++++++++++++
libgloss/configure.ac | 1 +
libgloss/sparc/Makefile.in | 2 +-
libgloss/sparc/acinclude.m4 | 6 +++---
5 files changed, 32 insertions(+), 5 deletions(-)
@@ -334,6 +334,7 @@ m4_include([mcore/acinclude.m4])
m4_include([mips/acinclude.m4])
m4_include([mn10300/acinclude.m4])
m4_include([moxie/acinclude.m4])
+m4_include([sparc/acinclude.m4])
m4_include([xtensa/acinclude.m4])
AC_CACHE_CHECK([for compiler search settings], libc_cv_compiler_isystem, [dnl
@@ -170,7 +170,7 @@ sparcl-stub.o: $(srcdir)/sparcl-stub.c $(srcdir)/../debug.h $(srcdir)/../debug.c
erc32-stub.o: $(srcdir)/erc32-stub.c $(srcdir)/../debug.h $(srcdir)/../debug.c
fixctors.o : $(srcdir)/fixctors.c
-$(objdir)/cygmon.ld: @SPARC_CYGMONLDSCRIPTTEMPL@
+$(objdir)/cygmon.ld: $(srcdir)/@SPARC_CYGMONLDSCRIPTTEMPL@
sed 's/TARGET_OBJ_FORMAT/$($(CPU)_OBJ_FORMAT)/g;s/TARGET_RAM_START/$($(CPU)_RAM_START)/g;' < $(<) > $(objdir)/cygmon.ld
install: $($(CPU)_INSTALL)
@@ -7,9 +7,9 @@ sparc86x*) SPARC_CPU=SLITE ;;
esac
AC_SUBST(SPARC_CPU)
-SPARC_CYGMONLDSCRIPTTEMPL=${srcdir}/sparc/cygmon.ld.src
+SPARC_CYGMONLDSCRIPTTEMPL=cygmon.ld.src
case ${target_cpu} in
-sparc64*) SPARC_CYGMONLDSCRIPTTEMPL=${srcdir}/sparc/cygmon-sparc64-ld.src ;;
-sparclet-*-aout*) SPARC_CYGMONLDSCRIPTTEMPL=${srcdir}/sparc/cygmon.ld.src; AC_CONFIG_FILES([sparc/libsys/Makefile]) ;;
+sparc64*) SPARC_CYGMONLDSCRIPTTEMPL=cygmon-sparc64-ld.src ;;
+sparclet-*-aout*) SPARC_CYGMONLDSCRIPTTEMPL=cygmon.ld.src; AC_CONFIG_FILES([sparc/libsys/Makefile]) ;;
esac
AC_SUBST(SPARC_CYGMONLDSCRIPTTEMPL)