[4/5] libgloss: msp430: delete custom .S.o rule

Message ID 20231227032453.13546-4-vapier@gentoo.org
State New
Headers
Series [1/5] libgloss: msp430: delete outdated/wrong code |

Commit Message

Mike Frysinger Dec. 27, 2023, 3:24 a.m. UTC
  This was added to specify -Wa,-gdwarf2 when compiling the assembly
files.  Considering the size of these .S files, it seems unnecessary
overkill and complicates the build system.  All but one of these
compile down to 6 or fewer lines, and those hardly need extra debug
for anyone who is poking msp430 assembly.  The 1 file that is larger
than that (crt_move_highdata.S) is still <15 insns.

This will also simplify merging it into the top-level Makefile.
---
 libgloss/msp430/Makefile.in | 4 ----
 1 file changed, 4 deletions(-)
  

Patch

diff --git a/libgloss/msp430/Makefile.in b/libgloss/msp430/Makefile.in
index ccf94dc1625f..62c8a280bcaa 100644
--- a/libgloss/msp430/Makefile.in
+++ b/libgloss/msp430/Makefile.in
@@ -96,10 +96,6 @@  CRT_OBJS = \
 
 all: $(CRT) $(SIM_BSP) $(LIB_NOSYS) $(LIB_CRT) copy_scripts_to_objdir
 
-# Override .S.o rule to pass assembler debugging flags
-.S.o:
-	$(CC) -Wa,-gdwarf2 -Wa,-I$(srcdir) $(CFLAGS_FOR_TARGET) $(INCLUDES) $(CFLAGS) -c $<
-
 $(SIM_BSP): $(SIM_OBJS)
 	$(AR) $(ARFLAGS) $@ $?
 	$(RANLIB) $@