libgloss: fix up incorrect "it's"

Message ID 20231226043527.18977-1-vapier@gentoo.org
State New
Headers
Series libgloss: fix up incorrect "it's" |

Commit Message

Mike Frysinger Dec. 26, 2023, 4:35 a.m. UTC
  ---
 libgloss/debug.c                            |  2 +-
 libgloss/doc/porting.texi                   | 16 ++++++++--------
 libgloss/hp74x/debugger.h                   |  2 +-
 libgloss/hp74x/debugger.s                   |  2 +-
 libgloss/hp74x/diagnose.h                   |  2 +-
 libgloss/hp74x/iva_table.h                  |  2 +-
 libgloss/hp74x/iva_table.s                  |  2 +-
 libgloss/hp74x/pa_stub.c                    |  2 +-
 libgloss/m32r/m32r-stub.c                   |  4 ++--
 libgloss/m68k/mvme-stub.c                   |  6 +++---
 libgloss/m68k/mvme135-asm.S                 |  2 +-
 libgloss/m68k/mvme162lx-asm.S               |  2 +-
 libgloss/sparc/crt0.S                       |  2 +-
 libgloss/sparc/sparc-stub.c                 |  2 +-
 libgloss/sparc/sparcl-stub.c                |  2 +-
 libgloss/sparc/sparclet-stub.c              |  2 +-
 libgloss/sparc_leon/kernel_sched.c          |  2 +-
 libgloss/testsuite/libgloss.all/Makefile.in |  2 +-
 libgloss/xstormy16/xstormy16_stub.c         |  4 ++--
 19 files changed, 30 insertions(+), 30 deletions(-)
  

Patch

diff --git a/libgloss/debug.c b/libgloss/debug.c
index 3b1c8ff9b7d5..d6fb89a5e08f 100644
--- a/libgloss/debug.c
+++ b/libgloss/debug.c
@@ -692,7 +692,7 @@  gdb_read_reg(int reg)
 
 /*
  * P - write one register.
- *	params are the register number, and it's new value.
+ *	params are the register number, and its new value.
  *	returns the register value or ENN.
  */
 char *
diff --git a/libgloss/doc/porting.texi b/libgloss/doc/porting.texi
index 15f214d026a4..5697a64d0b46 100644
--- a/libgloss/doc/porting.texi
+++ b/libgloss/doc/porting.texi
@@ -125,7 +125,7 @@  After a while it became apparent that this approach of isolating the
 hardware and systems files together made sense. Around this same time
 the stub dirs were made to run standalone, mostly so it could also be
 used to support GDB's remote debugging needs. At this time it was
-decided to move the stub dirs out of newlib and into it's own separate
+decided to move the stub dirs out of newlib and into its own separate
 library so it could be used standalone, and be included in various other
 GNU tools without having to bring in all of newlib, which is large. The
 new library is called Libgloss, for Gnu Low-level OS support. 
@@ -269,7 +269,7 @@  source tree, use:
 @end smallexample
 
 The configure script is in the source tree. When configure is invoked
-it will determine it's own source tree, so the --srcdir is would be
+it will determine its own source tree, so the --srcdir is would be
 redundant here.
 
 Once libgloss is configured, @code{make} is sufficient to build it. The
@@ -445,7 +445,7 @@  compiler passes. It will format command line options for the other passes.
 The usual command line GCC uses for the final link phase will have LD
 link in the startup code and additional libraries by default.
 
-GNU AS started it's life to only function as a compiler pass, but
+GNU AS started its life to only function as a compiler pass, but
 these days it can also be used as a source level assembler. When used as
 a source level assembler, it has a companion assembler preprocessor
 called @code{gasp}. This has a syntax similar to most other assembler
@@ -524,7 +524,7 @@  Pass the next option directly to the linker.
 To make a program that has been compiled with GCC to run, you
 need to write some startup code. The initial piece of startup code is
 called a crt0. (C RunTime 0) This is usually written in assembler, and
-it's object gets linked in first, and bootstraps the rest of the
+its object gets linked in first, and bootstraps the rest of the
 application when executed. This file needs to do the following things.
 
 @enumerate
@@ -550,7 +550,7 @@  This is what basically starts things running. If your ROM monitor
 supports it, then first setup argc and argv for command line arguments
 and an environment pointer. Then branch to main(). For G++ the the main
 routine gets a branch to __main inserted by the code generator at the
-very top.  __main() is used by G++ to initialize it's internal tables.
+very top.  __main() is used by G++ to initialize its internal tables.
 __main() then returns back to your original main() and your code gets
 executed.
 
@@ -760,7 +760,7 @@  the m68k-coff configuration defaults to not linking in the crt0.o by
 default. It assumes that the developer probably has their own crt0.o.
 This behavior is controlled in the config file for each architecture.
 It's a macro called @code{STARTFILE_SPEC}, and if it's set to
-@code{null}, then when @code{gcc} formats it's command line, it doesn't
+@code{null}, then when @code{gcc} formats its command line, it doesn't
 add @code{crto.o}. Any file name can be specified here, but the default
 is always @code{crt0.o}.
 
@@ -879,7 +879,7 @@  are setup here for use by the @code{crt0.o} when it zero's the
 
 A few ROM monitors load binary images, typically @code{a.out}, but most all
 will load an @code{srecord}. An srecord is an ASCII representation of a binary 
-image. At it's simplest, an srecord is an address, followed by a byte
+image. At its simplest, an srecord is an address, followed by a byte
 count, followed by the bytes, and a 2's compliment checksum. A whole
 srecord file has an optional @emph{start} record, and a required @emph{end} 
 record. To make an srecord from a binary image, the GNU @code{objcopy} program
@@ -901,7 +901,7 @@  typically they are stubbed out. Kill is also a stub, since you can't do
 process control on an embedded system. 
 
 Sbrk() is only needed by applications that do dynamic memory
-allocation. It's uses the symbol @code{_end} that is setup in the linker
+allocation. It uses the symbol @code{_end} that is setup in the linker
 script. It also requires a compile time option to set the upper size
 limit on the heap space. This leaves us with read and write, which are
 required for serial I/O. Usually these two routines are written in C,
diff --git a/libgloss/hp74x/debugger.h b/libgloss/hp74x/debugger.h
index 2c735987c3f9..81e515b171bb 100644
--- a/libgloss/hp74x/debugger.h
+++ b/libgloss/hp74x/debugger.h
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/hp74x/debugger.s b/libgloss/hp74x/debugger.s
index edf4e4b417a7..c3830acf6223 100644
--- a/libgloss/hp74x/debugger.s
+++ b/libgloss/hp74x/debugger.s
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/hp74x/diagnose.h b/libgloss/hp74x/diagnose.h
index 23eb84791e57..1d536a6334a0 100644
--- a/libgloss/hp74x/diagnose.h
+++ b/libgloss/hp74x/diagnose.h
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/hp74x/iva_table.h b/libgloss/hp74x/iva_table.h
index 68d6ba977664..afccce31341c 100644
--- a/libgloss/hp74x/iva_table.h
+++ b/libgloss/hp74x/iva_table.h
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/hp74x/iva_table.s b/libgloss/hp74x/iva_table.s
index 289ea3c94d4f..570df3fe7998 100644
--- a/libgloss/hp74x/iva_table.s
+++ b/libgloss/hp74x/iva_table.s
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/hp74x/pa_stub.c b/libgloss/hp74x/pa_stub.c
index 296492175622..42002cf889c2 100644
--- a/libgloss/hp74x/pa_stub.c
+++ b/libgloss/hp74x/pa_stub.c
@@ -19,7 +19,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/m32r/m32r-stub.c b/libgloss/m32r/m32r-stub.c
index 4d54f72d60b8..acc89ed6a215 100644
--- a/libgloss/m32r/m32r-stub.c
+++ b/libgloss/m32r/m32r-stub.c
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
@@ -46,7 +46,7 @@ 
  *
  *  Because gdb will sometimes write to the stack area to execute function
  *  calls, this program cannot rely on using the supervisor stack so it
- *  uses it's own stack area reserved in the int array remcomStack.
+ *  uses its own stack area reserved in the int array remcomStack.
  *
  *************
  *
diff --git a/libgloss/m68k/mvme-stub.c b/libgloss/m68k/mvme-stub.c
index fcf7e7bf02e8..32b40dba49f0 100644
--- a/libgloss/m68k/mvme-stub.c
+++ b/libgloss/m68k/mvme-stub.c
@@ -14,7 +14,7 @@  int cnt;
 		THIS SOFTWARE IS NOT COPYRIGHTED  
    
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the 
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
@@ -50,7 +50,7 @@  int cnt;
  *  Some explanation is probably necessary to explain how exceptions are
  *  handled.  When an exception is encountered the 68000 pushes the current
  *  program counter and status register onto the supervisor stack and then
- *  transfers execution to a location specified in it's vector table.
+ *  transfers execution to a location specified in its vector table.
  *  The handlers for the exception vectors are hardwired to jmp to an address
  *  given by the relation:  (exception - 256) * 6.  These are decending 
  *  addresses starting from -6, -12, -18, ...  By allowing 6 bytes for
@@ -69,7 +69,7 @@  int cnt;
  * 
  *  Because gdb will sometimes write to the stack area to execute function
  *  calls, this program cannot rely on using the supervisor stack so it
- *  uses it's own stack area reserved in the int array remcomStack.  
+ *  uses its own stack area reserved in the int array remcomStack.
  * 
  *************
  *
diff --git a/libgloss/m68k/mvme135-asm.S b/libgloss/m68k/mvme135-asm.S
index 1722c1804ae7..ea0a29826645 100644
--- a/libgloss/m68k/mvme135-asm.S
+++ b/libgloss/m68k/mvme135-asm.S
@@ -11,7 +11,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED  
    
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the 
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/m68k/mvme162lx-asm.S b/libgloss/m68k/mvme162lx-asm.S
index 8b83621d6dbe..2c29418a79d8 100644
--- a/libgloss/m68k/mvme162lx-asm.S
+++ b/libgloss/m68k/mvme162lx-asm.S
@@ -11,7 +11,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED  
    
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the 
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/sparc/crt0.S b/libgloss/sparc/crt0.S
index 501abf8ed93c..411808604106 100644
--- a/libgloss/sparc/crt0.S
+++ b/libgloss/sparc/crt0.S
@@ -103,7 +103,7 @@  copyloop:
 
 
 /*
- * Move the data segment from it's ROM address to RAM where it
+ * Move the data segment from its ROM address to RAM where it
  * belongs. 
  */
 
diff --git a/libgloss/sparc/sparc-stub.c b/libgloss/sparc/sparc-stub.c
index fa21d72cdb1f..675737341ca3 100644
--- a/libgloss/sparc/sparc-stub.c
+++ b/libgloss/sparc/sparc-stub.c
@@ -4,7 +4,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/sparc/sparcl-stub.c b/libgloss/sparc/sparcl-stub.c
index 634878bd7e78..960e1a666033 100644
--- a/libgloss/sparc/sparcl-stub.c
+++ b/libgloss/sparc/sparcl-stub.c
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/sparc/sparclet-stub.c b/libgloss/sparc/sparclet-stub.c
index a46212830407..e7dfebadfb92 100644
--- a/libgloss/sparc/sparclet-stub.c
+++ b/libgloss/sparc/sparclet-stub.c
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
diff --git a/libgloss/sparc_leon/kernel_sched.c b/libgloss/sparc_leon/kernel_sched.c
index 2b485c0fe3bc..9d625ce9eb37 100644
--- a/libgloss/sparc_leon/kernel_sched.c
+++ b/libgloss/sparc_leon/kernel_sched.c
@@ -55,7 +55,7 @@  leonbare_sched ()
   LEONBARE_KR_CURRENT = new;
 
   /* to be able to programm symetrically on kernel level each thread
-     saves it's spinlock on mutexes and kernel and irq flags in its
+     saves its spinlock on mutexes and kernel and irq flags in its
      own save region. On a kernel switch they are released until the
      thread is reawakened. Then the locks will be reaquired (and finally
      released when the codeblock exits). The locking can be recursive. */
diff --git a/libgloss/testsuite/libgloss.all/Makefile.in b/libgloss/testsuite/libgloss.all/Makefile.in
index fcade7998816..f33243d86d87 100644
--- a/libgloss/testsuite/libgloss.all/Makefile.in
+++ b/libgloss/testsuite/libgloss.all/Makefile.in
@@ -10,7 +10,7 @@  SHELL = /bin/sh
 SUPPORT=support.o
 
 #
-# to add a new test, put it's name here, and list the objects
+# to add a new test, put its name here, and list the objects
 # required too.
 TESTS= misc.x float.x io.x memory.x double.x math.x func.x div.x \
       printf.x varargs.x varargs2.x array.x struct.x misc.x
diff --git a/libgloss/xstormy16/xstormy16_stub.c b/libgloss/xstormy16/xstormy16_stub.c
index 7706031e9c61..7bd3bcef5f33 100644
--- a/libgloss/xstormy16/xstormy16_stub.c
+++ b/libgloss/xstormy16/xstormy16_stub.c
@@ -3,7 +3,7 @@ 
 		THIS SOFTWARE IS NOT COPYRIGHTED
 
    HP offers the following for use in the public domain.  HP makes no
-   warranty with regard to the software or it's performance and the
+   warranty with regard to the software or its performance and the
    user accepts the software "AS IS" with all faults.
 
    HP DISCLAIMS ANY WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD
@@ -41,7 +41,7 @@ 
  *
  *  Because gdb will sometimes write to the stack area to execute function
  *  calls, this program cannot rely on using the inferior stack so it uses
- *  it's own stack area.
+ *  its own stack area.
  *
  *************
  *