[PATCH/committed] newlib: fix AC_DEFINE quoting style with version macros

Message ID 20231015092819.27013-1-vapier@gentoo.org
State New
Headers
Series [PATCH/committed] newlib: fix AC_DEFINE quoting style with version macros |

Commit Message

Mike Frysinger Oct. 15, 2023, 9:28 a.m. UTC
  configure.ac files use [] for quoting by default, not "", which
means the "" are passed through as literals.  We don't want that
for these comments, so change the "..." to [...].

Pushed as "obvious".
---
 newlib/configure.ac | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
  

Patch

diff --git a/newlib/configure.ac b/newlib/configure.ac
index 97549ba32d84..94242c082d20 100644
--- a/newlib/configure.ac
+++ b/newlib/configure.ac
@@ -410,10 +410,10 @@  EOF
 fi
 AC_SUBST(EXEEXT_FOR_BUILD)
 
-AC_DEFINE(_NEWLIB_VERSION,"NEWLIB_VERSION","The newlib version in string format.")
-AC_DEFINE(__NEWLIB__,NEWLIB_MAJOR_VERSION,"The newlib major version number.")
-AC_DEFINE(__NEWLIB_MINOR__,NEWLIB_MINOR_VERSION,"The newlib minor version number.")
-AC_DEFINE(__NEWLIB_PATCHLEVEL__,NEWLIB_PATCHLEVEL_VERSION,"The newlib patch level.")
+AC_DEFINE(_NEWLIB_VERSION, "NEWLIB_VERSION", [The newlib version in string format.])
+AC_DEFINE(__NEWLIB__, NEWLIB_MAJOR_VERSION, [The newlib major version number.])
+AC_DEFINE(__NEWLIB_MINOR__, NEWLIB_MINOR_VERSION, [The newlib minor version number.])
+AC_DEFINE(__NEWLIB_PATCHLEVEL__, NEWLIB_PATCHLEVEL_VERSION, [The newlib patch level.])
 
 if test "${newlib_elix_level}" -gt "0"; then
   AC_DEFINE_UNQUOTED(_ELIX_LEVEL, ${newlib_elix_level}, [EL/IX level])