[1/2] gnu: Add gucharmap.
Commit Message
Hello,
On 2016-10-05 04:36, Hartmut Goebel wrote:
> This shout go into gnu/packages/gnome.scm. We do not add a file for
> every single application.
* I have updated the package.
* This package also includes the UNICODE license, according to
'https://www.gnu.org/licenses/license-list'; It is compatible with all
versions GPL.
Comments
Hi,
> + (synopsis "Character Map")
Looks like you missed my message:
Again, please be a bit more verbose. I do not even understand what a
"Character map" is (maybe this is an English idiom, but I'm no native
speaker.) Debian calls it "Unicode character picker and font browser",
which is more meaningful for me.
> + (description
> + "Character map, based on the Unicode Character Database.")
Again, please be more verbose. E-g- Debian:
This program allows you to browse through all the available Unicode
characters and categories for the installed fonts, and to examine
their detailed properties. It is an easy way to find the character
you might only know by its Unicode name or code point.
From d6ef1fc545b2fabaf9f2c38252809456b4b6c6cc Mon Sep 17 00:00:00 2001
From: Rene Saavedra <rennes@openmailbox.org>
Date: Wed, 5 Oct 2016 17:50:51 -0500
Subject: [PATCH 1/2] gnu: Add gucharmap.
* gnu/packages/gnome.scm (gucharmap): New variable.
---
gnu/packages/gnome.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -5543,3 +5543,33 @@ handling the startup notification side.")
"Calculator is an application that solves mathematical equations and
is suitable as a default application in a Desktop environment.")
(license license:gpl3)))
+
+(define-public gucharmap
+ (package
+ (name "gucharmap")
+ (version "3.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0c1q9w5vql0vvg6g0knxfnv4ap19fg5cdrwndi1cj9lsym92c78j"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources.
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("xmllint" ,libxml2)))
+ (home-page "https://wiki.gnome.org/Apps/Gucharmap")
+ (synopsis "Character Map")
+ (description
+ "Character map, based on the Unicode Character Database.")
+ (license license:gpl3)))
--
2.10.0