gnu: Add hdf4

Message ID alpine.DEB.2.20.1605231817490.16068@jpro.nerc-bas.ac.uk
State New
Headers

Commit Message

Jeremy Robst May 23, 2016, 5:22 p.m. UTC
  * gnu/packages/maths.scm (hdf4): New variable
---
  gnu/packages/maths.scm |   35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)
  

Comments

Leo Famulari May 23, 2016, 6:17 p.m. UTC | #1
On Mon, May 23, 2016 at 06:22:09PM +0100, Jeremy Robst wrote:

Welcome, and thanks for the patch!

Unfortunately, I can't seem to apply it to my source tree. Is anybody
else able to do so? I can't figure *why* it doesn't apply. Jeremy, are
you able to apply it with `patch -p1` or `git am`?

> +(define-public hdf4
> +  (package
> +    (name "hdf4")
> +    (version "4.2.11")
> +    (source +     (origin +       (method url-fetch)

This is strange. It renders as expected once the patch is downloaded,
but in Mutt, it looks like this. I wonder if this has to do with the
patch not applying?

> +    (arguments '(#:tests? #f))

We prefer to add a comment explaining why test are disabled. If there
are no tests, then the comment can be "No test suite."

> +    (license (license:x11-style
> +              "https://www.hdfgroup.org/ftp/HDF/HDF_Current/src/unpacked/COPYING"))))

To me, this looks more like a variation on the BSD license than the x11
license. Perhaps non-copyleft is a more appropriate choice. Can you look
at some of our packages using non-copyleft and report back?

Can you look into these questions and send an updated patch?
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 19ed44f..570cc32 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -408,6 +408,41 @@  plotting engine by third-party applications like Octave.")
      (license (license:fsf-free
                "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))

+(define-public hdf4
+  (package
+    (name "hdf4")
+    (version "4.2.11")
+    (source 
+     (origin 
+       (method url-fetch)
+       (uri (string-append
+             "http://www.hdfgroup.org/ftp/HDF/HDF_Current/src/hdf-"
+             version
+             ".tar.bz2"))
+       (sha256
+        (base32
+         "16yr50j845zlfx20skmw3y75ww77akk9gg0affjqkg66ih5r03mv"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gfortran" ,gfortran)
+       ("bison" ,bison)
+       ("flex" ,flex)))
+    (inputs
+     `(("zlib" ,zlib)
+       ("libjpeg" ,libjpeg)))
+    (arguments '(#:tests? #f))
+ 
+    (home-page "https://www.hdfgroup.org/products/hdf4/")
+    (synopsis
+     "Library and multi-object file format for storing and managing data")
+    (description "At its lowest level, HDF is a physical file format for
+storing scientific data.  At its highest level, HDF is a collection of
+utilities and applications for manipulating, viewing, and analyzing data
+in HDF files.  Between these levels, HDF is a software library that provides
+high-level APIs and a low-level data interface. ")
+    (license (license:x11-style
+              "https://www.hdfgroup.org/ftp/HDF/HDF_Current/src/unpacked/COPYING"))))
+
  (define-public hdf5
    (package
      (name "hdf5")