Commit Message
From da52c5897cb72056b18a1d1d5e94970b5c88d03b Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Fri, 27 May 2016 10:01:59 +0200
Subject: gnu: Add new variable (emacs-queue).
* gnu/packages/emacs.scm (emacs-queue): New variable.
---
@@ -1733,3 +1733,24 @@ package.el into a sane API.")
"This library extracts information from installed packages.
")
(license license:gpl3+)))
+
+(define-public emacs-queue
+ (package
+ (name "emacs-queue")
+ (version "0.1.1")
+ (source
+ (origin
+ (method uncompressed-file-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/queue-" version ".el"))
+ (sha256
+ (base32
+ "0jw24fxqnf9qcaf2nh09cnds1kqfk7hal35dw83x1ari95say391"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.dr-qubit.org/emacs.php")
+ (synopsis "Queue data structure")
+ (description
+ "These queues can be used both as a first-in last-out (FILO) and as a
+first-in first-out (FIFO) stack, i.e. elements can be added to the front or
+back of the queue, and can be removed from the front. (This type of data
+structure is sometimes called an \"output-restricted deque\")")
+ (license license:gpl3+)))
--
2.5.5