Commit Message
ahem
this is the same patch, only with a better log line
* gnu/packages/emacs.scm (emacs-smartparens): New variable.
---
gnu/packages/emacs.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
+
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=CEYP5YVHDRX8C
+")
+ (license license:gpl3+)))
@@ -1559,3 +1559,46 @@ to recognize a name like \"RFC 1234\". This package
enhances ffap so
that it correctly finds RFCs even when a space appears before the
number.")
(license license:gpl3+)))
+
+
+
+(define-public emacs-smartparens
+(package
+ (name "emacs-smartparens")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://stable.melpa.org/packages/smartparens-"
+ version
+ ".tar"))
+ (sha256
+ (base32
+ "04dvavsvmdf6fljv30csfkqkglvaw421irlq89v6zf93p0ak0vg6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-dash" ,emacs-dash))) ; what about cl-lib
0.3 ?
+ (native-inputs `(("emacs" ,emacs-no-x)))
+ (home-page "https://github.com/Fuco1/smartparens")
+ (synopsis
+ "Automatic insertion, wrapping and paredit-like navigation with user
defined pairs.")
+ (description
+ "Smartparens is minor mode for Emacs that deals with parens pairs
+and tries to be smart about it. It started as a unification effort
+to combine functionality of several existing packages in a single,
+compatible and extensible way to deal with parentheses, delimiters,
+tags and the like. Some of these packages include autopair,
+textmate, wrap-region, electric-pair-mode, paredit and others. With
+the basic features found in other packages it also brings many
+improvements as well as completely new features
+
+For a basic overview, see github readme at
+https://github.com/Fuco1/smartparens
+
+For the complete documentation visit the documentation wiki located
+at https://github.com/Fuco1/smartparens/wiki
+
+If you like this project, you can donate here: