Commit Message
From d8c560cd5b2335b01b19edec67cbd8a69e5ee3a4 Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Sun, 29 May 2016 13:44:00 +0200
Subject: gnu: Add emacs-seq.
* gnu/packages/emacs.scm (emacs-seq).
---
@@ -1770,3 +1770,33 @@ structure is sometimes called an \"output-restricted deque\")")
(description "Add spinners and progress-bars
to the mode-line for ongoing operations.")
(license license:gpl3+)))
+
+(define-public emacs-seq
+ (package
+ (name "emacs-seq")
+ (version "2.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://elpa.gnu.org/packages/seq-"
+ version ".tar"))
+ (sha256
+ (base32
+ "09wi1765bmn7i8fg6ajjfaxgs4ipc42d58zx2fdqpidrdg9c7q73"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/seq.html")
+ (synopsis "Sequence manipulation functions")
+ (description
+ "Sequence-manipulation functions that complement basic functions
+provided by @code{subr.el}
+
+All functions are prefixed with \"seq-\".
+
+All provided functions work on lists, strings and vectors.
+
+Functions taking a predicate or iterating over a sequence using a
+function as argument take the function as their first argument and
+the sequence as their second argument. All other functions take
+the sequence as their first argument.")
+ (license license:gpl3+)))
--
2.5.5