emacs-epl

Message ID CAJ98PDxURtvbMiu9c4LAcSyMGpEhTtbFEqhrtz7sSb30VKtLRA@mail.gmail.com
State New
Headers

Commit Message

Catonano May 26, 2016, 9:09 p.m. UTC
  
  

Comments

Alex Kost May 27, 2016, 8:11 a.m. UTC | #1
Catonano (2016-05-27 00:09 +0300) wrote:

> From 0d303576f88d00f2d3b58e7c452bcf575876b124 Mon Sep 17 00:00:00 2001
> From: humanitiesNerd <catonano@gmail.com>
> Date: Thu, 26 May 2016 01:31:30 +0200
> Subject: gnu: Add new variable (emacs-epl).

The name should be:

  gnu: Add emacs-epl.

> * gnu/packages/emacs.scm (emacs-epl): New variable.
> ---
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 967f583..e513dc6 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1684,3 +1684,28 @@ well as completely new features.")
>  refactoring for the @uref{http://clojure.org, Clojure programming language}.
>  It is recommended to use @code{clojure-mode} with paredit or smartparens.")
>      (license license:gpl3+)))
> +
> +(define-public emacs-epl
> +  (package
> +    (name "emacs-epl")
> +    (version "0.8")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://github.com/cask/epl/archive/"
> +             version
> +             ".tar.gz"))
> +       (sha256
> +        (base32
> +          "1511n3a3f5gvaf2b4nh018by61ciyzi3y3603fzqma7p9hrckarc"))))
> +    (build-system emacs-build-system)
> +    (home-page "http://github.com/cask/epl")
> +    (synopsis "Emacs Package Library")
> +    (description
> +     "A package management library for Emacs, based on package.el.

I wrapped "package.el" into @code{} structure.

> +
> +The purpose of this library is to wrap all the quirks and hassle of
> +package.el into a sane API.")
> +    (license license:gpl3+)))
> +

Applied as commit d345491ab4896dcf4f492bc4c8c7df2387991071, thanks!
  

Patch

From 0d303576f88d00f2d3b58e7c452bcf575876b124 Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Thu, 26 May 2016 01:31:30 +0200
Subject: gnu: Add new variable (emacs-epl).

* gnu/packages/emacs.scm (emacs-epl): New variable.
---

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 967f583..e513dc6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1684,3 +1684,28 @@  well as completely new features.")
 refactoring for the @uref{http://clojure.org, Clojure programming language}.
 It is recommended to use @code{clojure-mode} with paredit or smartparens.")
     (license license:gpl3+)))
+
+(define-public emacs-epl
+  (package
+    (name "emacs-epl")
+    (version "0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/cask/epl/archive/"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+          "1511n3a3f5gvaf2b4nh018by61ciyzi3y3603fzqma7p9hrckarc"))))
+    (build-system emacs-build-system)
+    (home-page "http://github.com/cask/epl")
+    (synopsis "Emacs Package Library")
+    (description
+     "A package management library for Emacs, based on package.el.
+
+The purpose of this library is to wrap all the quirks and hassle of
+package.el into a sane API.")
+    (license license:gpl3+)))
+
-- 
2.5.5